summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Bone2023-03-22 20:51:05 -0400
committerAshley Bone2023-03-22 20:51:05 -0400
commit13619c37acb89d5a4195a9166f3c6f827404c195 (patch)
tree45df4a4ef40492aeecc868118ffd66b6f5767d0a
parentb108aaef69060ddd56392eaa5d053cedeb85dd0c (diff)
downloadaur-13619c37acb89d5a4195a9166f3c6f827404c195.tar.gz
Update to 2.7.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e461e41c5fe..fd33a6bb1c5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = healthchecks
pkgdesc = A cron monitoring service with a web-based dashboard, API, and notification integrations.
- pkgver = 2.6.1
+ pkgver = 2.7.0
pkgrel = 1
url = https://github.com/healthchecks/healthchecks
install = healthchecks.install
@@ -23,7 +23,7 @@ pkgbase = healthchecks
optdepends = python-apprise: Add support for the Apprise integration.
backup = var/lib/healthchecks/local_settings.py
backup = etc/uwsgi/healthchecks.ini
- source = https://github.com/healthchecks/healthchecks/archive/refs/tags/v2.6.1.tar.gz
+ source = https://github.com/healthchecks/healthchecks/archive/refs/tags/v2.7.tar.gz
source = hc-clean-db
source = hc-manage
source = healthchecks-clean-db.service
@@ -35,7 +35,7 @@ pkgbase = healthchecks
source = healthchecks.tmpfiles
source = local_settings.py
source = settings.patch
- sha256sums = 3a203a086104553c2c99ca02611b3ba3d357f5d58b56c99880d84a8078e43f80
+ sha256sums = 8781b00846bc148362d1fe3cb791ec3f4ac2b9b574ab1ff09967c559852679f1
sha256sums = a7b75bdd35c6952e06e1cd3824450f7c613aff5e3fb1d9f4f57f517b57cefbde
sha256sums = 355ac237284642e24a3cbe7ddb285bf7dbb802e72ea7fe7c68f0476178ab94fc
sha256sums = 9d32c4d1404079cac9b7a4ccbc97e01d867735c2536f915220d2ac5dffc333e7
diff --git a/PKGBUILD b/PKGBUILD
index b2e3da9f06bc..b930e802d54a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Ashley Bone <ashley DOT bone AT pm DOT me>
pkgname=healthchecks
-pkgver=2.6.1
+_pkgver=2.7
+pkgver=2.7.0
pkgrel=1
pkgdesc="A cron monitoring service with a web-based dashboard, API, and notification integrations."
arch=('any')
@@ -14,7 +15,7 @@ optdepends=('python-psycopg2: Add support for postgreSQL.'
'python-apprise: Add support for the Apprise integration.')
backup=("var/lib/$pkgname/local_settings.py" "etc/uwsgi/$pkgname.ini")
install="$pkgname.install"
-source=("$url/archive/refs/tags/v$pkgver.tar.gz"
+source=("$url/archive/refs/tags/v$_pkgver.tar.gz"
"hc-clean-db"
"hc-manage"
"$pkgname-clean-db.service"
@@ -26,7 +27,7 @@ source=("$url/archive/refs/tags/v$pkgver.tar.gz"
"$pkgname.tmpfiles"
"local_settings.py"
"settings.patch")
-sha256sums=('3a203a086104553c2c99ca02611b3ba3d357f5d58b56c99880d84a8078e43f80'
+sha256sums=('8781b00846bc148362d1fe3cb791ec3f4ac2b9b574ab1ff09967c559852679f1'
'a7b75bdd35c6952e06e1cd3824450f7c613aff5e3fb1d9f4f57f517b57cefbde'
'355ac237284642e24a3cbe7ddb285bf7dbb802e72ea7fe7c68f0476178ab94fc'
'9d32c4d1404079cac9b7a4ccbc97e01d867735c2536f915220d2ac5dffc333e7'
@@ -40,13 +41,13 @@ sha256sums=('3a203a086104553c2c99ca02611b3ba3d357f5d58b56c99880d84a8078e43f80'
'6daf90731364cfb1b80fb94438d93891be6565cbbf220fbe4ba11b1f3fdbc777')
prepare () {
- cd "$pkgname-$pkgver/hc"
+ cd "$pkgname-$_pkgver/hc"
echo $(pwd)
patch -p0 -i '../../settings.patch'
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$_pkgver"
# create the python compiled files, static-collected files and an initial database
python -m compileall .
@@ -55,12 +56,12 @@ build() {
}
check() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$_pkgver"
./manage.py test
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$_pkgver"
# create directories
install -dm755 "$pkgdir/etc/uwsgi"