summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Bone2023-06-08 09:30:35 -0400
committerAshley Bone2023-06-08 09:30:35 -0400
commit7ab071ef68ab6c57823167c1a32495e2de5e7ca2 (patch)
tree601ec6cc61b99fa35ed8572625fbe266d475de12
parenta01c7b80a1884d9b27f0330c2608f3d84472a1c2 (diff)
downloadaur-7ab071ef68ab6c57823167c1a32495e2de5e7ca2.tar.gz
Update to 2.9.2.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--settings.patch14
3 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8825bcc5849a..82584ebad642 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = healthchecks
pkgdesc = A cron monitoring service with a web-based dashboard, API, and notification integrations.
- pkgver = 2.8.1
+ pkgver = 2.9.2
pkgrel = 1
url = https://github.com/healthchecks/healthchecks
install = healthchecks.install
arch = any
license = BSD
+ depends = python-aiosmtpd
depends = python-cron-descriptor
depends = python-cronsim
depends = python-django
@@ -23,7 +24,7 @@ pkgbase = healthchecks
optdepends = python-apprise: Add support for the Apprise integration.
backup = var/lib/healthchecks/local_settings.py
backup = etc/uwsgi/healthchecks.ini
- source = https://github.com/healthchecks/healthchecks/archive/refs/tags/v2.8.1.tar.gz
+ source = https://github.com/healthchecks/healthchecks/archive/refs/tags/v2.9.2.tar.gz
source = hc-clean-db
source = hc-manage
source = healthchecks-clean-db.service
@@ -35,7 +36,7 @@ pkgbase = healthchecks
source = healthchecks.tmpfiles
source = local_settings.py
source = settings.patch
- sha256sums = ff851b1e5042e1a1bef9b569a7e55e3d114f1943a612bf3c1a245a92b4646569
+ sha256sums = 64f7fec9d43aeddd80ac7065e15c4556868aee0ec7caa4441d6c50610727b539
sha256sums = a7b75bdd35c6952e06e1cd3824450f7c613aff5e3fb1d9f4f57f517b57cefbde
sha256sums = 355ac237284642e24a3cbe7ddb285bf7dbb802e72ea7fe7c68f0476178ab94fc
sha256sums = 9d32c4d1404079cac9b7a4ccbc97e01d867735c2536f915220d2ac5dffc333e7
@@ -46,6 +47,6 @@ pkgbase = healthchecks
sha256sums = 2407d81ae0224d5c394b35e20a3b29d138fbde3fdde951de9dfea44d97e73eca
sha256sums = c04de046d176958b3705d751ac09cf018d395b6c37f38977ec4048a561d5041f
sha256sums = 4cb8857de8ef834e0e41eddc56a3e7bbab63adb210196642ca2544b48220f31d
- sha256sums = 6daf90731364cfb1b80fb94438d93891be6565cbbf220fbe4ba11b1f3fdbc777
+ sha256sums = 86dbe0d8ac731908833848fdae056722f10a10647c5256eab4413e80663f23ca
pkgname = healthchecks
diff --git a/PKGBUILD b/PKGBUILD
index 28694926ce29..a488cc2061f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Ashley Bone <ashley DOT bone AT pm DOT me>
pkgname=healthchecks
-_pkgver=2.8.1
-pkgver=2.8.1
+_pkgver=2.9.2
+pkgver=2.9.2
pkgrel=1
pkgdesc="A cron monitoring service with a web-based dashboard, API, and notification integrations."
arch=('any')
url="https://github.com/healthchecks/healthchecks"
license=('BSD')
-depends=('python-cron-descriptor' 'python-cronsim' 'python-django' 'python-django-compressor'
- 'python-fido2' 'python-pyotp' 'python-pytz' 'python-pycurl' 'python-segno'
- 'python-statsd' 'python-whitenoise' 'uwsgi' 'uwsgi-plugin-python')
+depends=('python-aiosmtpd' 'python-cron-descriptor' 'python-cronsim' 'python-django'
+ 'python-django-compressor' 'python-fido2' 'python-pyotp' 'python-pytz' 'python-pycurl'
+ 'python-segno' 'python-statsd' 'python-whitenoise' 'uwsgi' 'uwsgi-plugin-python')
optdepends=('python-psycopg2: Add support for postgreSQL.'
'python-apprise: Add support for the Apprise integration.')
backup=("var/lib/$pkgname/local_settings.py" "etc/uwsgi/$pkgname.ini")
@@ -31,7 +31,7 @@ source=("$url/archive/refs/tags/v$_pkgver.tar.gz"
"$pkgname.tmpfiles"
"local_settings.py"
"settings.patch")
-sha256sums=('ff851b1e5042e1a1bef9b569a7e55e3d114f1943a612bf3c1a245a92b4646569'
+sha256sums=('64f7fec9d43aeddd80ac7065e15c4556868aee0ec7caa4441d6c50610727b539'
'a7b75bdd35c6952e06e1cd3824450f7c613aff5e3fb1d9f4f57f517b57cefbde'
'355ac237284642e24a3cbe7ddb285bf7dbb802e72ea7fe7c68f0476178ab94fc'
'9d32c4d1404079cac9b7a4ccbc97e01d867735c2536f915220d2ac5dffc333e7'
@@ -42,7 +42,7 @@ sha256sums=('ff851b1e5042e1a1bef9b569a7e55e3d114f1943a612bf3c1a245a92b4646569'
'2407d81ae0224d5c394b35e20a3b29d138fbde3fdde951de9dfea44d97e73eca'
'c04de046d176958b3705d751ac09cf018d395b6c37f38977ec4048a561d5041f'
'4cb8857de8ef834e0e41eddc56a3e7bbab63adb210196642ca2544b48220f31d'
- '6daf90731364cfb1b80fb94438d93891be6565cbbf220fbe4ba11b1f3fdbc777')
+ '86dbe0d8ac731908833848fdae056722f10a10647c5256eab4413e80663f23ca')
prepare () {
cd "$pkgname-$_pkgver/hc"
diff --git a/settings.patch b/settings.patch
index 99c35cf7af80..334eec5b776e 100644
--- a/settings.patch
+++ b/settings.patch
@@ -1,10 +1,10 @@
---- settings.py 2022-01-07 05:17:22.000000000 -0500
-+++ new_settings.py 2022-03-03 18:25:16.093628103 -0500
-@@ -171,6 +171,7 @@
+--- settings.py 2023-06-08 09:04:51.081561846 -0400
++++ settings.py.new 2023-06-08 09:13:53.774076650 -0400
+@@ -177,6 +177,7 @@
+ "django.contrib.staticfiles.finders.AppDirectoriesFinder",
+ "compressor.finders.CompressorFinder",
)
++COMPRESS_ENABLED=True
COMPRESS_OFFLINE = True
COMPRESS_CSS_HASHING_METHOD = "content"
-+COMPRESS_ENABLED = True
-
-
- def immutable_file_test(path, url):
+ COMPRESS_STORAGE = "compressor.storage.GzipCompressorFileStorage"