summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Bone2023-04-12 10:21:41 -0400
committerAshley Bone2023-04-12 10:21:41 -0400
commita01c7b80a1884d9b27f0330c2608f3d84472a1c2 (patch)
tree0fec439d5e5cacc4e1a67ac27df7bec7faebb2e8
parent13619c37acb89d5a4195a9166f3c6f827404c195 (diff)
downloadaur-a01c7b80a1884d9b27f0330c2608f3d84472a1c2.tar.gz
Update to 2.8.1.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd33a6bb1c5d..8825bcc5849a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = healthchecks
pkgdesc = A cron monitoring service with a web-based dashboard, API, and notification integrations.
- pkgver = 2.7.0
+ pkgver = 2.8.1
pkgrel = 1
url = https://github.com/healthchecks/healthchecks
install = healthchecks.install
@@ -23,7 +23,7 @@ pkgbase = healthchecks
optdepends = python-apprise: Add support for the Apprise integration.
backup = var/lib/healthchecks/local_settings.py
backup = etc/uwsgi/healthchecks.ini
- source = https://github.com/healthchecks/healthchecks/archive/refs/tags/v2.7.tar.gz
+ source = https://github.com/healthchecks/healthchecks/archive/refs/tags/v2.8.1.tar.gz
source = hc-clean-db
source = hc-manage
source = healthchecks-clean-db.service
@@ -35,7 +35,7 @@ pkgbase = healthchecks
source = healthchecks.tmpfiles
source = local_settings.py
source = settings.patch
- sha256sums = 8781b00846bc148362d1fe3cb791ec3f4ac2b9b574ab1ff09967c559852679f1
+ sha256sums = ff851b1e5042e1a1bef9b569a7e55e3d114f1943a612bf3c1a245a92b4646569
sha256sums = a7b75bdd35c6952e06e1cd3824450f7c613aff5e3fb1d9f4f57f517b57cefbde
sha256sums = 355ac237284642e24a3cbe7ddb285bf7dbb802e72ea7fe7c68f0476178ab94fc
sha256sums = 9d32c4d1404079cac9b7a4ccbc97e01d867735c2536f915220d2ac5dffc333e7
diff --git a/PKGBUILD b/PKGBUILD
index b930e802d54a..28694926ce29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Ashley Bone <ashley DOT bone AT pm DOT me>
pkgname=healthchecks
-_pkgver=2.7
-pkgver=2.7.0
+_pkgver=2.8.1
+pkgver=2.8.1
pkgrel=1
pkgdesc="A cron monitoring service with a web-based dashboard, API, and notification integrations."
arch=('any')
@@ -15,6 +15,10 @@ optdepends=('python-psycopg2: Add support for postgreSQL.'
'python-apprise: Add support for the Apprise integration.')
backup=("var/lib/$pkgname/local_settings.py" "etc/uwsgi/$pkgname.ini")
install="$pkgname.install"
+
+# other ways of specifying source from github:
+# source=("git+$url#tag=v$pkgver")
+# source=('project_name::git+https://project_url#branch=project_branch')
source=("$url/archive/refs/tags/v$_pkgver.tar.gz"
"hc-clean-db"
"hc-manage"
@@ -27,7 +31,7 @@ source=("$url/archive/refs/tags/v$_pkgver.tar.gz"
"$pkgname.tmpfiles"
"local_settings.py"
"settings.patch")
-sha256sums=('8781b00846bc148362d1fe3cb791ec3f4ac2b9b574ab1ff09967c559852679f1'
+sha256sums=('ff851b1e5042e1a1bef9b569a7e55e3d114f1943a612bf3c1a245a92b4646569'
'a7b75bdd35c6952e06e1cd3824450f7c613aff5e3fb1d9f4f57f517b57cefbde'
'355ac237284642e24a3cbe7ddb285bf7dbb802e72ea7fe7c68f0476178ab94fc'
'9d32c4d1404079cac9b7a4ccbc97e01d867735c2536f915220d2ac5dffc333e7'
@@ -72,7 +76,7 @@ package() {
install -dm755 "$pkgdir/var/lib/$pkgname"
# install healthchecks
- cp -r {hc,locale,__pycache__,static,static-collected,stuff,templates} "$pkgdir/usr/share/webapps/$pkgname/"
+ cp -r {hc,__pycache__,static,static-collected,stuff,templates} "$pkgdir/usr/share/webapps/$pkgname/"
install -Dm755 manage.py "$pkgdir/usr/share/webapps/$pkgname/"
install -Dm644 CHANGELOG.md "$pkgdir/usr/share/webapps/$pkgname/"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/"