summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYIGIT DALLILAR2017-11-02 22:19:00 -0400
committerYIGIT DALLILAR2017-11-02 22:19:00 -0400
commit2d5f87bcc35c067e3f3dc283bb1d32eac8850712 (patch)
tree571910193f89a3bb1c32493234dc675c8f5d93e5
parent3ab7a11c04c96839c5af30687f0e9a3599c819eb (diff)
downloadaur-2d5f87bcc35c067e3f3dc283bb1d32eac8850712.tar.gz
upgrade to v6.22.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
-rw-r--r--heasoft-6.21_nolynx.patch12
3 files changed, 11 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae62b450239b..7927d1e5d0d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = heasoft
pkgdesc = NASA high energy astrophysics library
- pkgver = 6.21
- pkgrel = 3
+ pkgver = 6.22.1
+ pkgrel = 1
url = https://heasarc.gsfc.nasa.gov/docs/software/lheasoft/
arch = x86_64
license = NASA
@@ -11,14 +11,10 @@ pkgbase = heasoft
makedepends = gcc-fortran
makedepends = perl
depends = ncurses
- depends = libtinfo
depends = readline
depends = libxpm
- optdepends = lynx
- source = http://heasarc.gsfc.nasa.gov/FTP/software/lheasoft/release/heasoft-6.21src_no_xspec_modeldata.tar.gz
- source = heasoft-6.21_nolynx.patch
- sha1sums = 3c55645feae3ddffc86d6c1b3c1b989e8a7d5d1b
- sha1sums = c1d4940d1aa599bf3b8b61b3471ebf057869b517
+ source = http://heasarc.gsfc.nasa.gov/FTP/software/lheasoft/release/heasoft-6.22.1src_no_xspec_modeldata.tar.gz
+ sha256sums = 86d5b0be442f4eb80cf60f2160a87527e615bb019d1dabdc102d9864b6ec8b96
pkgname = heasoft
diff --git a/PKGBUILD b/PKGBUILD
index afba460c746d..2566254d51c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,17 @@
# Maintainer: Yigit Dallilar <yigit.dallilar@gmail.com>
pkgname=heasoft
-pkgver=6.21
-pkgrel=3
+pkgver=6.22.1
+pkgrel=1
pkgdesc="NASA high energy astrophysics library"
makedepends=("gcc" "glibc" "gcc-fortran" "perl")
-depends=("ncurses" "libtinfo" "readline" "libxpm" )
-optdepends=("lynx")
+depends=("ncurses" "readline" "libxpm" )
url="https://heasarc.gsfc.nasa.gov/docs/software/lheasoft/"
arch=('x86_64')
license=('NASA' 'GPL')
-source=(http://heasarc.gsfc.nasa.gov/FTP/software/lheasoft/release/${pkgname}-${pkgver}src_no_xspec_modeldata.tar.gz ${pkgname}-${pkgver}_nolynx.patch)
-sha1sums=('3c55645feae3ddffc86d6c1b3c1b989e8a7d5d1b'
- 'c1d4940d1aa599bf3b8b61b3471ebf057869b517')
-
-prepare() {
- # lynx conflict with ncurses and openssl. For now left it out.
- # lynx can be installed from official repo.
- cd $srcdir/${pkgname}-${pkgver}
- patch -Np1 -i ../${pkgname}-${pkgver}_nolynx.patch
- echo
-}
+source=(http://heasarc.gsfc.nasa.gov/FTP/software/lheasoft/release/${pkgname}-${pkgver}src_no_xspec_modeldata.tar.gz)
+#source=(heasoft-6.22.1src_no_xspec_modeldata.tar.gz)
+sha256sums=('86d5b0be442f4eb80cf60f2160a87527e615bb019d1dabdc102d9864b6ec8b96')
build() {
@@ -50,18 +41,7 @@ package(){
echo "***********************************************************************"
echo
- if [ -e /usr/bin/lynx ]
- then
- echo "Checking if lynx is installed... yes"
- echo "Linking lynx to heasoft"
- ln -s /usr/bin/lynx $pkgdir/opt/${pkgname}-${pkgver}/x86_64-unknown-linux-gnu-libc${_glibcver}/bin/lynx
-
- else
- echo "Checking if lynx is installed... no"
- fi
-
-
- printf "\n\nAdd following lines to your ~/.bashrc to initialize the software\n\n export HEADAS=/opt/%s-%s/x86_64-unknown-linux-gnu-libc%s\n alias heainit='source \$HEADAS/headas-init.sh\n\nThen load heasoft by the command:\n\n >heainit\n\n" ${pkgname} ${pkgver} ${_glibcver}
+ printf "\n\nAdd following lines to your ~/.bashrc to initialize the software\n\n export HEADAS=/opt/%s-%s/x86_64-unknown-linux-gnu-libc%s\n alias heainit='source \$HEADAS/headas-init.sh\n\nThen load heasoft by the command:\n\n >heainit\n\n" ${pkgname} ${pkgver} ${_glibcver}
echo "Install complete..."
echo
diff --git a/heasoft-6.21_nolynx.patch b/heasoft-6.21_nolynx.patch
index 5e4b70ffb92f..e69de29bb2d1 100644
--- a/heasoft-6.21_nolynx.patch
+++ b/heasoft-6.21_nolynx.patch
@@ -1,12 +0,0 @@
-diff -ura heasoft-6.21/BUILD_DIR/configure heasoft-6.21_nolynx/BUILD_DIR/configure
---- heasoft-6.21/BUILD_DIR/configure 2016-12-16 15:53:03.000000000 -0500
-+++ heasoft-6.21_nolynx/BUILD_DIR/configure 2017-05-02 00:11:51.775658396 -0400
-@@ -2341,7 +2341,7 @@
-
- for dir in $HD_SELECTED; do
- if test -d $h_top/heacore/fhelp; then
-- lynx_required=yes
-+ lynx_required=no
- fi
- if test `echo $dir | grep -c hitomi` -ne 0; then
- ahfits_required=yes