summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Dallilar2017-05-04 01:27:29 -0400
committerYigit Dallilar2017-05-04 01:27:29 -0400
commit3ab7a11c04c96839c5af30687f0e9a3599c819eb (patch)
treece7109bb55b7ab98fffff2dfd530510fb92ea2fa
parentabb04c5ab04a4d5b736e064c7b0282acbdfdac06 (diff)
downloadaur-3ab7a11c04c96839c5af30687f0e9a3599c819eb.tar.gz
Explaing how to initialize the software and link lynx to heasoft if installed
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD31
2 files changed, 30 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab9e696cb496..ae62b450239b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = heasoft
pkgdesc = NASA high energy astrophysics library
pkgver = 6.21
- pkgrel = 2
+ pkgrel = 3
url = https://heasarc.gsfc.nasa.gov/docs/software/lheasoft/
arch = x86_64
license = NASA
diff --git a/PKGBUILD b/PKGBUILD
index 4da7d3c14b36..afba460c746d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=heasoft
pkgver=6.21
-pkgrel=2
+pkgrel=3
pkgdesc="NASA high energy astrophysics library"
makedepends=("gcc" "glibc" "gcc-fortran" "perl")
depends=("ncurses" "libtinfo" "readline" "libxpm" )
@@ -18,7 +18,8 @@ prepare() {
# lynx conflict with ncurses and openssl. For now left it out.
# lynx can be installed from official repo.
cd $srcdir/${pkgname}-${pkgver}
- patch -Np1 -i ../${pkgname}-${pkgver}_nolynx.patch
+ patch -Np1 -i ../${pkgname}-${pkgver}_nolynx.patch
+ echo
}
@@ -41,5 +42,31 @@ package(){
cd $srcdir/${pkgname}-${pkgver}/BUILD_DIR
make install
+ _glibcver=$(pacman -Q glibc | cut -c7-10)
+
+ mkdir -p $pkgdir/opt/${pkgname}-${pkgver}/x86_64-unknown-linux-gnu-libc${_glibcver}/bin/
+
+ echo
+ echo "***********************************************************************"
+ echo
+
+ if [ -e /usr/bin/lynx ]
+ then
+ echo "Checking if lynx is installed... yes"
+ echo "Linking lynx to heasoft"
+ ln -s /usr/bin/lynx $pkgdir/opt/${pkgname}-${pkgver}/x86_64-unknown-linux-gnu-libc${_glibcver}/bin/lynx
+
+ else
+ echo "Checking if lynx is installed... no"
+ fi
+
+
+ printf "\n\nAdd following lines to your ~/.bashrc to initialize the software\n\n export HEADAS=/opt/%s-%s/x86_64-unknown-linux-gnu-libc%s\n alias heainit='source \$HEADAS/headas-init.sh\n\nThen load heasoft by the command:\n\n >heainit\n\n" ${pkgname} ${pkgver} ${_glibcver}
+
+ echo "Install complete..."
+ echo
+ echo "***********************************************************************"
+ echo
+
}