summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Dallilar2017-05-02 16:45:36 -0400
committerYigit Dallilar2017-05-02 16:45:36 -0400
commitddd4f09a2ded7da4def8883a3dde7df6afc6de8a (patch)
treeab653aae22703cf8d99e8ba0f30dfdd8b966c5a9
downloadaur-ddd4f09a2ded7da4def8883a3dde7df6afc6de8a.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD98
-rw-r--r--heasoft-6.21_nolynx.patch12
3 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57734f218c77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = heasoft
+ pkgver = 6.21
+ pkgrel = 1
+ url = https://heasarc.gsfc.nasa.gov/docs/software/lheasoft/
+ arch = x86_64
+ license = NASA
+ license = GPL
+ makedepends = gcc
+ makedepends = glibc
+ makedepends = gcc-fortran
+ makedepends = perl
+ depends = ncurses
+ depends = libtinfo
+ depends = readline
+ depends = libxpm
+ source = http://heasarc.gsfc.nasa.gov/FTP/software/lheasoft/release/heasoft-6.21src_no_xspec_modeldata.tar.gz
+ source = heasoft-6.21_nolynx.patch
+ sha1sums = 3a315e28f55df904b66a268dfc51b8d5f2c2a0b3
+ sha1sums = c1d4940d1aa599bf3b8b61b3471ebf057869b517
+
+pkgname = heasoft-base
+
+pkgname = xspec
+ depends = heasoft-base
+
+pkgname = ftools
+ depends = heasoft-base
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d15c848de98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,98 @@
+# Maintainer: Yigit Dallilar <yigit.dallilar@gmail.com>
+
+pkgbase=heasoft
+_mainpkg=heasoft
+_mainver=6.21
+_crntpkg=''
+pkgname=('heasoft-base' 'xspec' 'ftools')
+pkgver=6.21
+pkgrel=1
+makedepends=("gcc" "glibc" "gcc-fortran" "perl")
+depends=("ncurses" "libtinfo" "readline" "libxpm" )
+url="https://heasarc.gsfc.nasa.gov/docs/software/lheasoft/"
+arch=('x86_64')
+license=('NASA' 'GPL')
+source=(http://heasarc.gsfc.nasa.gov/FTP/software/lheasoft/release/${pkgbase}-${pkgver}src_no_xspec_modeldata.tar.gz ${pkgbase}-${pkgver}_nolynx.patch)
+sha1sums=('3a315e28f55df904b66a268dfc51b8d5f2c2a0b3'
+ 'c1d4940d1aa599bf3b8b61b3471ebf057869b517')
+
+prepare() {
+ # lynx conflict with ncurses and openssl. For now left it out.
+ cd $srcdir/${pkgbase}-${pkgver}
+ patch -Np1 -i ../${pkgbase}-${pkgver}_nolynx.patch
+}
+
+
+build() {
+
+ export CC=/usr/bin/gcc
+ export CXX=/usr/bin/g++
+ export FC=/usr/bin/gfortran
+ export PERL=/usr/bin/perl
+
+ cd $srcdir/${_mainpkg}-${pkgver}/BUILD_DIR
+ ./configure --prefix=$pkgdir/opt/$pkgbase-$pkgver
+
+ make
+
+}
+
+package_heasoft-base(){
+
+ _crntpkg='heasoft-base'
+ packagedsc='Base libraries for heasoft software'
+ pkgver=6.21
+
+ cd $srcdir/$pkgbase-${_mainver}/BUILD_DIR
+ ./configure --prefix=$pkgdir/opt/$pkgbase-${_mainver}
+ make "HD_SELECTED=heacore tcltk heatool heagen attitude" install
+
+}
+
+# Remove common files
+_clean_conflict () {
+
+ export _glibcver=$(ldd --version | head -n1 | cut -d' ' -f4)
+
+ echo $pkgdir/opt/${_mainpkg}-$pkgver/x86_64-unknown-linux-gnu-libc${_glibcver}/BUILD_DIR/
+
+ rm -rf $pkgdir/opt/${_mainpkg}-$pkgver/x86_64-unknown-linux-gnu-libc${_glibcver}/BUILD_DIR/
+ rm -rf $pkgdir/opt/${_mainpkg}-$pkgver/x86_64-unknown-linux-gnu-libc${_glibcver}/bin/hd_install
+ rm -rf $pkgdir/opt/${_mainpkg}-$pkgver/x86_64-unknown-linux-gnu-libc${_glibcver}/bin/hd_scanenv
+ rm -rf $pkgdir/opt/${_mainpkg}-$pkgver/x86_64-unknown-linux-gnu-libc${_glibcver}/bin/hmake
+ rm -rf $pkgdir/opt/${_mainpkg}-$pkgver/x86_64-unknown-linux-gnu-libc${_glibcver}/bin/lhea-fixperl
+ rm -rf $pkgdir/opt/${_mainpkg}-$pkgver/x86_64-unknown-linux-gnu-libc${_glibcver}/headas-init.csh
+ rm -rf $pkgdir/opt/${_mainpkg}-$pkgver/x86_64-unknown-linux-gnu-libc${_glibcver}/headas-init.sh
+
+}
+
+package_xspec(){
+
+ _crntpkg='xspec'
+ packagedsc='X-ray spectral fitting software'
+ pkgver=6.21
+ depends=('heasoft-base')
+
+ cd $srcdir/$pkgbase-${_mainver}/BUILD_DIR
+ ./configure --prefix=$pkgdir/opt/$pkgbase-${_mainver}
+ make "HD_SELECTED=Xspec" install
+
+ _clean_conflict
+
+}
+
+package_ftools(){
+
+ _crntpkg='ftools'
+ packagedsc='A General Package of Software to Manipulate FITS Files'
+ pkgver=6.21
+ depends=('heasoft-base')
+
+ cd $srcdir/$pkgbase-${_mainver}/BUILD_DIR
+ ./configure --prefix=$pkgdir/opt/$pkgbase-${_mainver}
+ make "HD_SELECTED=ftools" install
+
+ _clean_conflict
+
+}
+
diff --git a/heasoft-6.21_nolynx.patch b/heasoft-6.21_nolynx.patch
new file mode 100644
index 000000000000..5e4b70ffb92f
--- /dev/null
+++ b/heasoft-6.21_nolynx.patch
@@ -0,0 +1,12 @@
+diff -ura heasoft-6.21/BUILD_DIR/configure heasoft-6.21_nolynx/BUILD_DIR/configure
+--- heasoft-6.21/BUILD_DIR/configure 2016-12-16 15:53:03.000000000 -0500
++++ heasoft-6.21_nolynx/BUILD_DIR/configure 2017-05-02 00:11:51.775658396 -0400
+@@ -2341,7 +2341,7 @@
+
+ for dir in $HD_SELECTED; do
+ if test -d $h_top/heacore/fhelp; then
+- lynx_required=yes
++ lynx_required=no
+ fi
+ if test `echo $dir | grep -c hitomi` -ne 0; then
+ ahfits_required=yes