summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOctelly2023-09-20 16:54:12 +0200
committerOctelly2023-09-20 16:54:12 +0200
commita5261937ccacdf5a97f35dce0a3c7b61bf0808a5 (patch)
tree22301c12a60d02df2d610b57ac30fef50ce6e05c
parentce90659380591edeba9858a0a915bcca59a13e53 (diff)
downloadaur-a5261937ccacdf5a97f35dce0a3c7b61bf0808a5.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rwxr-xr-xPKGBUILD54
-rw-r--r--heaven-studio.desktop10
-rw-r--r--install.sh78
-rwxr-xr-xtest.sh1
5 files changed, 60 insertions, 108 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cdebff70562..41cf2cef1b41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,17 @@
-pkgbase = pkgbase
- pkgdesc = osfetch-sh is a stupid system fetch program written in bash for linux. (git version)
- pkgver = r17.ec5682d
- pkgrel = 1
- url = https://github.com/mzakyr12/osfetch-sh
- arch = any
- license = MIT
- makedepends = git
- source = git+https://github.com/mzakyr12/osfetch-sh.git
+pkgbase = heaven-studio-nightly-bin
+ pkgdesc = Fully playable, open source recreation of every Rhythm Heaven minigame with a built in level editor.
+ pkgver = 6241434638
+ pkgrel = 6
+ url = https://github.com/RHeavenStudio/HeavenStudio
+ arch = x86_64
+ license = GPL3
+ makedepends = unzip
+ makedepends = tar
+ provides = heaven-studio
+ noextract = StandaloneLinux64-build.zip
+ source = https://nightly.link/RHeavenStudio/HeavenStudio/actions/runs/6241434638/StandaloneLinux64-build.zip
+ source = heaven-studio.desktop
+ sha512sums = SKIP
sha512sums = SKIP
-pkgname = osfetch-sh-git
+pkgname = heaven-studio-nightly-bin
diff --git a/PKGBUILD b/PKGBUILD
index 982b66221798..e0a27423a1d2 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,41 @@
-# Maintainer: Muhammad Zaky Ramadhan <mzakyr42@gmail.com>
+# Maintainer: Eli Štefků "Octelly" <eli@stefek.cz>
-pkgbase=pkgbase
-pkgname=osfetch-sh-git
-_pkgname=osfetch-sh
-pkgver=r17.ec5682d
-pkgrel=1
-pkgdesc="osfetch-sh is a stupid system fetch program written in bash for linux. (git version)"
-arch=('any')
-url="https://github.com/mzakyr12/${_pkgname}"
-license=('MIT')
-makedepends=('git')
-source=("git+https://github.com/mzakyr12/${_pkgname}.git")
-sha512sums=('SKIP')
+pkgname=heaven-studio-nightly-bin
+provides=("heaven-studio")
+_pkgname=heaven-studio
+pkgver=6241434638
+# note: Couldn't find a proper versioning system for this project
+pkgrel=6
+pkgdesc="Fully playable, open source recreation of every Rhythm Heaven minigame with a built in level editor."
+arch=('x86_64')
+url="https://github.com/RHeavenStudio/HeavenStudio"
+license=('GPL3')
+source=(
+ "https://nightly.link/RHeavenStudio/HeavenStudio/actions/runs/${pkgver}/StandaloneLinux64-build.zip"
+ 'heaven-studio.desktop'
+)
+noextract=("StandaloneLinux64-build.zip")
+sha512sums=(
+ 'SKIP'
+ 'SKIP'
+)
+makedepends=('unzip' 'tar')
-pkgver() {
- cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+prepare() {
+ unzip StandaloneLinux64-build.zip
+ rm StandaloneLinux64-build.zip
+ tar -xvf StandaloneLinux64.tar
+ rm StandaloneLinux64.tar
}
package() {
- cd $_pkgname
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/osfetch-sh-git/LICENSE"
- install -D -m755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+ cd build/StandaloneLinux64
+ find . -type f -exec install -v -Dm 755 "{}" "$pkgdir/opt/$_pkgname/{}" \;
+
+ mkdir -p $pkgdir/usr/share/icons/hicolor/128x128/apps
+ ln -sf $pkgdir/opt/heaven-studio/Heaven\ Studio_Data/Resources/UnityPlayer.png $pkgdir/usr/share/icons/hicolor/128x128/apps/heaven-studio.png
+
+ mkdir -p $pkgdir/usr/share/applications
+ cd ../..
+ install -Dm 755 "heaven-studio.desktop" $pkgdir/usr/share/applications
}
diff --git a/heaven-studio.desktop b/heaven-studio.desktop
new file mode 100644
index 000000000000..ab06d50a4e56
--- /dev/null
+++ b/heaven-studio.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Heaven Studio
+Comment=Fully playable, open source recreation of every Rhythm Heaven minigame with a built in level editor.
+Exec="/opt/heaven-studio/Heaven Studio" %f
+Icon=heaven-studio
+Terminal=False
+Categories=Game;ActionGame;ArcadeGame;Music
+Keywords=Rhythm Heaven;Rhythm Paradise;Rhythm World;Rhythm Tengoku;RHeavenStudio;Rhythm Heaven Mania
diff --git a/install.sh b/install.sh
deleted file mode 100644
index ddc8827df6df..000000000000
--- a/install.sh
+++ /dev/null
@@ -1,78 +0,0 @@
-basename=slk-eng
-pkgname=dict-freedict-$basename
-dictd_conf=/etc/dict/dictd.conf
-datadir=/usr/share/dictd
-conf="database $basename {
- data $datadir/$basename.dict.dz
- index $datadir/$basename.index
-}"
-
-post_install()
-{
- echo
- if pacman -Qq dictd > /dev/null 2>&1
- then
- if grep -q "^database *$basename" "$dictd_conf"
- then
- echo "$pkgname already configured in $dictd_conf"
- else
- echo "Adding configuration for $pkgname to $dictd_conf"
- echo "$conf" >> "$dictd_conf"
- fi
-
- if systemctl -q is-active dictd.service
- then
- echo "Restarting dictd service in order to" \
- "use the new dictionary database"
- systemctl restart dictd.service
- else
- echo "Starting dictd service in order to" \
- "use the new dictionary database"
- systemctl start dictd.service
- fi
- else
- echo "dictd does not appear to be installed."
- echo "In order to use this database you should either" \
- "install dictd or alternatively" \
- "another dict server and configure it on your own."
- fi
- echo
-}
-
-post_upgrade()
-{
- if pacman -Qq dictd > /dev/null 2>&1 && \
- systemctl -q is-active dictd.service
- then
- echo -e "\nRestarting dictd service in order to" \
- "use the updated dictionary database"
- systemctl restart dictd.service
- fi
-}
-
-post_remove()
-{
- if pacman -Qq dictd > /dev/null 2>&1
- then
- current_conf="$(grep -A 3 "^database *$basename" "$dictd_conf")"
- if test -n "$current_conf"
- then
- echo
- if test "$current_conf" = "$conf"
- then
- echo "Removing configuration for $pkgname from $dictd_conf"
- sed -i "/database $basename {/,/}/d" "$dictd_conf"
- else
- echo "User created / modified configuration" \
- "for $pkgname in $dictd_conf is left untouched."
- fi
- fi
-
- if systemctl -q is-active dictd.service
- then
- echo "Restarting dictd service in order to" \
- "stop using the removed dictionary database"
- systemctl restart dictd.service
- fi
- fi
-}
diff --git a/test.sh b/test.sh
deleted file mode 100755
index 36f0670f54d0..000000000000
--- a/test.sh
+++ /dev/null
@@ -1 +0,0 @@
-echo 'test'