summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHendrik R2015-06-08 15:24:24 +0200
committerHendrik R2015-06-08 15:30:06 +0200
commitca0f9417b3de962b8e550f4daf618731ef1eb1df (patch)
tree54711d47038bc77bc87ec6b5cb3a549fcdecc382
downloadaur-ca0f9417b3de962b8e550f4daf618731ef1eb1df.tar.gz
Pong AUR4
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD66
-rw-r--r--heavybullets.desktop9
-rw-r--r--hello.txt222
5 files changed, 322 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bfec2d0f51a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = heavybullets-hib
+ pkgdesc = A randomized FPS dungeon crawler where players make their way through a colorful maze, while protecting themselves from aggressive creatures and malfunctioning security devices. (Humble Bundle Version)
+ pkgver = 1.05
+ pkgrel = 1
+ url = http://heavybullets.com
+ changelog = hello.txt
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = glu
+ depends = gcc-libs-multilib
+ source = hib://HEAVYBULLETS_105_LNX.tar.gz
+ source = heavybullets.desktop
+ sha256sums = b4b8732bbc87773a8db84cbed3a0d942a5462c14984b317af5dcc154a5272c05
+ sha256sums = e10ed2722ab1cbe7921c2cc39ca6eb66c5e9d45e0717f26d6171d74137c6f1c7
+ depends_i686 = gtk2
+ depends_x86_64 = lib32-gtk2
+
+pkgname = heavybullets-hib
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..78869a5f4b15
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*x86_64.pkg.tar
+*.src.tar.gz
+HEAVYBULLETS_*_LNX.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bdb3727d106e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Hendrik R. hendrikr_10 [at] yahoo [dot] de
+
+# I didn't test this on i686!
+# For any improvements please leave a comment in the AUR
+# or send a PR to https://github.com/He-Ro/aur-packages
+
+pkgname=heavybullets-hib
+pkgver=1.05
+_hibfile=HEAVYBULLETS_105_LNX.tar.gz
+pkgrel=1
+pkgdesc='A randomized FPS dungeon crawler where players make their way through a colorful maze, while protecting themselves from aggressive creatures and malfunctioning security devices. (Humble Bundle Version)'
+url='http://heavybullets.com'
+arch=('i686' 'x86_64')
+license=('custom:commercial')
+options=()
+depends=('glu'
+ 'gcc-libs-multilib')
+depends_x86_64=('lib32-gtk2')
+depends_i686=('gtk2')
+changelog='hello.txt'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+source=("hib://${_hibfile}"
+ "heavybullets.desktop")
+sha256sums=('b4b8732bbc87773a8db84cbed3a0d942a5462c14984b317af5dcc154a5272c05'
+ 'e10ed2722ab1cbe7921c2cc39ca6eb66c5e9d45e0717f26d6171d74137c6f1c7')
+
+package() {
+ _target="/opt/${pkgname}"
+ case $CARCH in
+ i686)
+ _arch=x86
+ ;;
+ x86_64)
+ _arch=x86_64
+ ;;
+ esac
+
+ mkdir -p "${pkgdir}${_target}"
+ cp -r "${srcdir}/HEAVY_BULLETS_Data" \
+ "${pkgdir}${_target}/"
+
+ # Fix permissions
+ find "${pkgdir}" -type f -exec chmod 644 "{}" +
+ chown root:root -R "${pkgdir}"
+
+ install -Dm755 "${srcdir}/HEAVY_BULLETS.${_arch}" \
+ "${pkgdir}${_target}/HEAVY_BULLETS"
+
+ # Install desktop entry
+ install -Dm644 "${srcdir}/heavybullets.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Install icon
+ install -Dm644 "${pkgdir}${_target}/HEAVY_BULLETS_Data/Resources/UnityPlayer.png" \
+ "${pkgdir}/usr/share/pixmaps/HeavyBullets.png"
+
+ # Install launcher symlink
+ install -d "${pkgdir}/usr/bin"
+ cat <<EOF > "${pkgdir}/usr/bin/heavybullets"
+#!/bin/sh
+/opt/${pkgname}/HEAVY_BULLETS
+EOF
+ chmod 755 "${pkgdir}/usr/bin/heavybullets"
+}
+
+# vim: tabstop=2 expandtab
diff --git a/heavybullets.desktop b/heavybullets.desktop
new file mode 100644
index 000000000000..c716368c3597
--- /dev/null
+++ b/heavybullets.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Heavy Bullets
+GenericName=Heavy Bullets
+Icon=/opt/heavybullets-hib/HEAVY_BULLETS_Data/Resources/UnityPlayer.png
+Exec="/opt/heavybullets-hib/HEAVY_BULLETS"
+Categories=Game;
+Path=/opt/heavybullets-hib
+
diff --git a/hello.txt b/hello.txt
new file mode 100644
index 000000000000..3cc3f691704c
--- /dev/null
+++ b/hello.txt
@@ -0,0 +1,222 @@
+
+
+
+H E A V Y
+B U L L E T S
+
+
+V1.05 October 11 2014
+http://www.heavybullets.com
+
+by TERRI VELLMANN, DOSEONE, DEVOLVER DIGITAL
+
+
+- CHANGES:
+V1.05
+- Fixed ORE CHUNK max text
+- Tweaked enemy collisions
+- Tweaked audio systems & performance
+- Tweaked WASP movement patterns
+- Added RELOAD tooltip
+- Fixed ITEM name bug (in Portuguese)
+- Fixed TURRET BOSS non aggressive bug
+- PAUSE now triggered when game loses focus
+
+V1.04
+- Fixed WASP bug
+
+V1.03
+- Fixed INVERTED MOUSE w RAW INPUT bug
+- Fixed CURSED GEM bug
+
+V1.02
+- Added FPS CAP settings
+- Added MOUSE SMOOTHING toggle
+- Fixed bug where ROCKETS couldn't be shot into BOSS ROOMS
+- Fixed invulnerability bug
+- Optimization tweaks
+- Fixed SAVEGAME bug with CARRY ITEM LVL
+
+V1.01
+- Tweaked VSYNC OFF FPS settings
+- Fixed getting HURT while game is PAUSED
+- Tweaked TURRET shot speed
+- Fixed gaps in LEVEL GENERATION
+- Optimization Tweaks
+- Update Unity engine to 4.5.4
+- Finer MOUSE SENSITIVITY and FOV settings
+- Fixed HOMING BOMB, ROCKET and MEGABOMB + BACKPACK SWAP exploit
+- Fixed dropping ITEMS + BACKPACK SWAP or PICKUP NEW ITEM bug
+
+V1.00
+- Added STEAM ACHIEVEMENTS & LEADERBOARDS
+- Tweaked ENEMY AI & LEVEL GENERATION
+
+V0.27
+- Fixed GOLD SKULL bug where ENEMIES wouldn't die
+- Fixed flipped DEAD END signs
+
+V0.26
+- Fixed bug where ITEM would get stuck
+
+V0.25
+- Added PORTUGUESE BR language support
+- Fixed bug when taking damage after using END LEVEL HATCH
+- Fixed bug where BLACK POTION was overriding POISON IMMUNITY
+- Tweaked SETTINGS text alignment
+- Removed blur from IMAGE EFFECTS
+- Performance tweaks
+
+V0.24
+- Fixed SCOPE/BACKPACK FOV bug
+- Performance tweaks
+- INTRO TEXT tweaks
+
+V0.23
+- Added new PROPS, COLORS and LIGHT changes throughout the game.
+- Added 4 ITEMS that spawn behind SECRET DOORS
+- Replaced BLOODSUCKER enemy with LEECH TURRET
+- Replaced INTRO and END GAME texts
+- Tweaked enemy AI
+- Added GLOBAL SOUND VOLUME options
+- Moved INVERT Y AXIS and LOOK SENSITIVY to CONTROLS
+- Tweaked GAMEPAD support
+- Tweaked SOUNDS
+- Can now find COINS instead of ORES when breaking ROCKS with the PICKAXE
+
+V0.22
+- Added SAVE & QUIT option to LEVEL TRANSITION screen / RESUME to TITLE SCREEN
+- Added LOG to PAUSE SCREEN
+- Tweaked SOUNDS
+- Added DISRUPTOR item
+- Fixed SPIKED HELMET storage bug
+
+V0.21
+- Fixed INVERTED Y AXIS bug
+
+V0.20
+- Added new MUSIC
+- Added GAMEPAD support
+- Changed YOU DIED screen
+- Open DOORS spawn lasers after PLAYER clears enough distance
+- Tweaked WASPS AI
+- BOMBS don't explode until thrown
+- Tweaked BOMB throwing
+- Fixed PICKAXE rock break bug
+- Raised starting MAGNETS to LVL1
+- Tweaked LEVEL GENERATION
+- EFFECTS blur tweaked, now calculated from screen height instead of width
+- AA settings expanded with AA type options
+- BLESSED GEM now has change to break after activated
+- Standard FOV set to 90
+- Max FOV set to 120
+
+V0.19
+- Fixed ITEM PRICE bug
+
+V0.18
+- Added and tweaked many SOUNDs
+- $10 added to global prices every 2 levels
+- Individual MEDBAYs can now only HEAL 3 times
+- HEALTH UP prices tweaked
+- DISCOUNT + price not affected by discount
+- Fixed multiple DIAMONDS bug
+- Activating a HATCH will cancel FOCUS
+- Tweaked FLYING TURRET collision
+- GOLD & BLACK POTION CARRY MAX reduced
+- LEVEL GENERATION expanded
+- Using a RITUAL BLADE will yield less MONEY
+- Fixed BOSS DOOR barrier bug
+- Fixed WIN MUSIC playing if music is off bug
+- Fixed KILLED BY stat on QUIT GAME
+- Fixed DIAMOND CARRY MAX text
+- VSYNC now can be set in the QUALITY settings
+- MAX MUSIC VOLUME setting added
+- ENEMY AI tweaks
+
+V0.17
+- EGGS now no longer spawn enemies, but explode on proximity
+- LEVEL 8 BOSS tweaked
+- Many SOUND tweaks and changes
+- FOV settings added
+- Raised MOUSELOOK sensitivity
+- Fixed bug where COIN MAGNETS would turn into GOLD SKULLS when stored
+- RITUAL BLADE turns into KNIFE when stored
+- ENEMY AI aggro tweaked
+- POISON SERUM now only affects player once
+- Change RELOADER description text
+- Killed by stat added to GAME OVER screen
+- Added 30% DISCOUNT level
+- STATS and SETTINGS can be reset individually
+
+V0.16
+- TELEPORT is reset when entering BOSS ROOM
+- Fixed THROW GLOVE infinite sell bug
+- Fixed PAUSE MENU bugs on some aspect ratios
+- Fixed LIFE hidden on some aspect ratios
+- Fixed MOUSE SENSITIVITY set from TITLE SCREEN
+- Fixed LOW HEART LOOP volume shifts
+
+V0.15
+- Fixed BANK WITHDRAW bug
+
+V0.14
+- DOSESONE contributes with MUSIC and SFX!
+- DEVOLVER DIGITAL logo splash screen added
+- TELEPORTER and PROXIMITY SENSOR now spawn as chest items
+- 6 BULLETS removed from chest item spawns
+- UI redesigned, information split into different screens
+- Fixed SLOW TURRET bug where it would freeze
+- Added AUTO ROCKET TURRET spawns
+- Added 1 new SECRET ITEM
+- PICKAXE attack now hits enemies as well as rocks
+- Fixed ROCKET/TALL GRASS bug
+- Added IMAGE EFFECTS (and options to turn them off)
+- Added LOW HEALTH MUSIC and IMAGE EFFECTS
+- TELEPORTER's PORTAL can be cancelled by holding down ITEM KEY
+- SCREEN FLASH when LEECH STONE HEALS.
+- Fixed ITEM EFFECT description bug when using BACKPACK
+- LAST WILL cancels LIFE INSURANCE (possible exploit fix)
+- Darkened GRASS
+
+V0.12
+- Fixed SLOW TURRET bug where you kept moving slowly after killing it
+- Enemies AI line of sight bug tweaked
+- UI blinks when you pick something up
+- Added instructions when you equip a BACKPACK
+- Added CLICK SOUND when reloading with a full chamber
+- Added 1 new item that spawns in SECRET WALLS
+- Fixed bug where a passive item's TOOLTIP would be wrong when you started a new level
+- BANK now has SELL ITEM and ITEM STORAGE (persistent) options
+- Added VALUABLE ITEMS (SMALL ORE, ORE CHUNK, DIAMOND, HEAVY ORE)
+- TURRETS play sound when activated
+- Added new SPAWN BLOCKS with various props (trees, boulders)
+- Added HIGH GRASS VEGETATION (blocks line of sight)
+- INTRO TEXT added on NEW GAME, END TEXT added on GAME WON, PROGRESS BAR added on level progression
+- Tweaked POTION model
+- Tweaked BULLET and COIN jumps
+
+V0.11
+- QUIT GAME added to MAIN MENU
+- ITEM DESCRIPTION added to PAUSE SCREEN
+- LOWER DIFFICULTY: Raised enemy reaction delay, lowered movement speed
+- SKULL ICON added over BOSS AREA's doors
+- LOGO removed from VENDING MACHINES
+- POISON damage is slower
+- Item description SPACE TO ACTIVATE changed to USE ITEM
+- TURRET PROJECTILE collision and speed tweaked
+- Fixed flipped VM bug.
+- Added 3 items that spawn in SECRET WALLS
+- New game now starts with 5 bullets loaded, 1 in the inventory
+
+
+
+Feedback is welcome!
+DEVLOG: http://www.heavybullets.com/devlog
+TWITTER: @terrivellmann
+EMAIL: terrivellmann@gmail.com
+
+Thanks
+
+- Terri Vellmann
+