summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVekhir2024-01-25 21:34:04 +0100
committerVekhir2024-01-25 21:34:04 +0100
commitadf23fc488df28f36931d79d4a28861129f40421 (patch)
tree1e36206feffdaea51f9905e8307048733b75a9bc
parentc5c6dbb7cceaaccdbcd5edf2de4df79ce8143095 (diff)
downloadaur-adf23fc488df28f36931d79d4a28861129f40421.tar.gz
refactor: Use upstream version of sdl2-mixer.patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--sdl2-mixer.patch16
3 files changed, 4 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b482a049485c..2b8599dc0c73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -27,8 +27,8 @@ pkgbase = hedgewars-client-hg
conflicts = hedgewars
conflicts = hedgewars-hg
source = hedgewars-client-hg::hg+https://hg.hedgewars.org/hedgewars/
- source = sdl2-mixer.patch
+ source = sdl2-mixer.patch::https://hg.hedgewars.org/hedgewars/raw-rev/bb847fe6d51c
sha512sums = SKIP
- sha512sums = bfb318a7f084cf65d470a4306f014f0adec677b1215519a246b54f3e40865972253721447604b7651a4b1b90aae2f8a4470e59e2b7dd6f3035bb4a42a89c1faa
+ sha512sums = 8dcb8a73d03f331c52d8d8ddbe8f867fcbe803a2e4fdee876deda13473ebd2bf8ba01927d5775ffaed96ef94772f8cdabf1891e7693f1a28d96c4224389daef9
pkgname = hedgewars-client-hg
diff --git a/PKGBUILD b/PKGBUILD
index 8f09a3707b3c..38fea20b0089 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,9 @@ optdepends=('hedgewars-server')
provides=('hedgewars-client')
conflicts=('hedgewars' 'hedgewars-hg')
source=("$pkgname::hg+https://hg.hedgewars.org/hedgewars/"
- "sdl2-mixer.patch")
+ "sdl2-mixer.patch::https://hg.hedgewars.org/hedgewars/raw-rev/bb847fe6d51c")
sha512sums=('SKIP'
- 'bfb318a7f084cf65d470a4306f014f0adec677b1215519a246b54f3e40865972253721447604b7651a4b1b90aae2f8a4470e59e2b7dd6f3035bb4a42a89c1faa')
+ '8dcb8a73d03f331c52d8d8ddbe8f867fcbe803a2e4fdee876deda13473ebd2bf8ba01927d5775ffaed96ef94772f8cdabf1891e7693f1a28d96c4224389daef9')
pkgver() {
cd "$pkgname"
diff --git a/sdl2-mixer.patch b/sdl2-mixer.patch
deleted file mode 100644
index 7bd2e20aa923..000000000000
--- a/sdl2-mixer.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ru a/QTfrontend/CMakeLists.txt b/QTfrontend/CMakeLists.txt
---- a/QTfrontend/CMakeLists.txt 2024-01-15 23:35:38.544868616 +0100
-+++ b/QTfrontend/CMakeLists.txt 2024-01-16 11:46:47.795047328 +0100
-@@ -14,7 +14,11 @@
- include(CheckLibraryExists)
-
- find_package(SDL2 REQUIRED CONFIG)
--find_package(SDL2_mixer REQUIRED CONFIG) #audio in SDLInteraction
-+if(WIN32 AND VCPKG_TOOLCHAIN)
-+ find_package(SDL2_mixer REQUIRED CONFIG) #audio in SDLInteraction
-+else()
-+ find_package(SDL2_mixer 2 REQUIRED) #audio in SDLInteraction
-+endif()
- include_directories(${SDL2_INCLUDE_DIRS})
- include_directories(${SDL2_MIXER_INCLUDE_DIRS})
-