summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112018-12-11 00:36:49 +0100
committerjose17112018-12-11 00:36:49 +0100
commitad79db61564ebfc15f1d18c973caba78f0fa3e07 (patch)
tree8f69ca327446ee47d62377a7b1782544f34a2291
parent7f7ca834653347da672610363599eaaf30e44cb7 (diff)
downloadaur-ad79db61564ebfc15f1d18c973caba78f0fa3e07.tar.gz
Update/fix deps + generate icons in multiple res
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD42
2 files changed, 42 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd441b617d8f..dff1d2b64f9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 24 21:45:12 UTC 2017
+# Mon Dec 10 23:36:35 UTC 2018
pkgbase = hedgewars-hg
pkgdesc = Free Worms-like turn based strategy game (development version - mercurial)
- pkgver = r12150.bbefbd1a3b0a
+ pkgver = r14415+.06672690d71b+
pkgrel = 1
url = http://hedgewars.org
arch = i686
@@ -11,30 +11,33 @@ pkgbase = hedgewars-hg
license = custom
makedepends = fpc
makedepends = cmake
- makedepends = mercurial
+ makedepends = qt5-tools
makedepends = ghc
makedepends = haskell-network
makedepends = haskell-bytestring-show
- makedepends = haskell-utf8-string
- makedepends = haskell-hslogger
- makedepends = haskell-vector
- makedepends = haskell-entropy
- makedepends = haskell-sha
makedepends = haskell-zlib
- makedepends = haskell-random
- makedepends = haskell-base-compat
- makedepends = haskell-sandi
- makedepends = haskell-regex-compat-tdfa
- makedepends = sdl2_net
- makedepends = sdl2_ttf
- depends = qt4
- depends = sdl_mixer
- depends = sdl_image
- depends = sdl_net
- depends = sdl_ttf
+ makedepends = haskell-base-prelude
+ makedepends = imagemagick
+ makedepends = mesa
+ depends = qt5-base
+ depends = sdl2
+ depends = sdl2_mixer
+ depends = sdl2_image
+ depends = sdl2_net
+ depends = sdl2_ttf
depends = lua51
- depends = physfs
depends = ffmpeg
+ depends = glut
+ depends = physfs
+ depends = ghc-libs
+ depends = haskell-entropy
+ depends = haskell-sha
+ depends = haskell-random
+ depends = haskell-regex-tdfa
+ depends = haskell-sandi
+ depends = haskell-hslogger
+ depends = haskell-utf8-string
+ depends = haskell-vector
conflicts = hedgewars
source = hedgewars-hg::hg+https://hg.hedgewars.org/hedgewars
source = hedgewars.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 04f4bde65607..c32c3cab60a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,17 @@
# Maintainer: Jozef Riha <jose1711 at gmail dot com>
pkgname=hedgewars-hg
-pkgver=r12150.bbefbd1a3b0a
+pkgver=r14415+.06672690d71b+
pkgrel=1
pkgdesc="Free Worms-like turn based strategy game (development version - mercurial)"
arch=('i686' 'x86_64')
url="http://hedgewars.org"
license=('GPL' 'custom')
-depends=('qt4' 'sdl_mixer' 'sdl_image' 'sdl_net' 'sdl_ttf' 'lua51' 'physfs' 'ffmpeg')
-makedepends=('fpc' 'cmake' 'mercurial'
-'ghc'
-'haskell-network'
-'haskell-bytestring-show'
-'haskell-utf8-string'
-'haskell-hslogger'
-'haskell-vector'
-'haskell-entropy'
-'haskell-sha'
-'haskell-zlib'
-'haskell-random'
-'haskell-base-compat'
-'haskell-sandi'
-'haskell-regex-compat-tdfa'
-'sdl2_net'
-'sdl2_ttf')
+depends=('qt5-base' 'sdl2' 'sdl2_mixer' 'sdl2_image' 'sdl2_net' 'sdl2_ttf' 'lua51' 'ffmpeg' 'glut'
+ 'physfs' 'ghc-libs' 'haskell-entropy' 'haskell-sha' 'haskell-random' 'haskell-regex-tdfa'
+ 'haskell-sandi' 'haskell-hslogger' 'haskell-utf8-string' 'haskell-vector')
+makedepends=('fpc' 'cmake' 'qt5-tools' 'ghc' 'haskell-network' 'haskell-bytestring-show'
+ 'haskell-zlib' 'haskell-base-prelude' 'imagemagick' 'mesa')
source=("${pkgname}"::'hg+https://hg.hedgewars.org/hedgewars' \
hedgewars.desktop \
hedgewars.png)
@@ -39,27 +27,35 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
- sed -i 's|instance NFData (Chan a)$|instance NFData (Chan a) where rnf x = seq x ()|' gameServer/CoreTypes.hs
+ sed -i 's|set(ghc_flags|set(ghc_flags -dynamic|' gameServer/CMakeLists.txt
}
build() {
cd ${srcdir}/${pkgname}
mkdir -p $srcdir/bin
- #cmake -DCMAKE_INSTALL_PREFIX=/usr -DDATA_INSTALL_DIR=/usr/share -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake -DQT_MOC_EXECUTABLE=/usr/bin/moc || return 1
- ln -sf /usr/bin/lrelease-qt4 $srcdir/bin/Qt4::lrelease
- export PATH=$srcdir/bin:$PATH
cmake \
-DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DDATA_INSTALL_DIR=/usr/share/hedgewars \
-DNOSERVER=0 .
make
+
+ # resize icon
+ for _size in 16 32 48 64 128 256; do
+ convert +set date:create +set date:modify misc/hedgewars.png -resize ${_size}x${_size} hedgewars_${_size}.png
+ done
}
package() {
cd ${srcdir}/${pkgname}
make DESTDIR=$pkgdir install
install -D -m644 Fonts_LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/Fonts_LICENSE.txt
- install -D -m644 $srcdir/hedgewars.png $pkgdir/usr/share/pixmaps/hedgewars.png
install -D -m644 $srcdir/hedgewars.desktop $pkgdir/usr/share/applications/hedgewars.desktop
+
+ # install icons
+ install -D -m644 misc/hedgewars.png "$pkgdir"/usr/share/icons/hicolor/512x512/apps/hedgewars.png
+ for _size in 16 32 48 64 128 256; do
+ install -D -m644 hedgewars_${_size}.png "$pkgdir"/usr/share/icons/hicolor/${_size}x${_size}/apps/hedgewars.png
+ done
+ rm -rf "$pkgdir"/usr/share/pixmaps
}