summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttenuation2018-11-15 14:20:33 +0800
committerAttenuation2018-11-15 14:20:33 +0800
commit6158b32bc7a5279fbedcbc09a30647303cd16cb1 (patch)
treeb3a10d374ab83c23d3bb14e0170b8ae26a5d48f6
parented5ac3206334ed9a23ac8548abe540e09b557d23 (diff)
downloadaur-6158b32bc7a5279fbedcbc09a30647303cd16cb1.tar.gz
add dependency lm_sensors
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a40e052cf8f9..c87dc55ff2ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = hegemon
pkgdesc = A modular system monitor written in Rust
pkgver = 20181013.085336
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/p-e-w/hegemon
arch = x86_64
license = GPL-3.0
makedepends = rust
+ depends = lm_sensors
source = hegemon::git+https://github.com/p-e-w/hegemon
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 373da46a1b3b..6c04a6644cdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Attenuation <ouyangjun1999@gmail.com>
pkgname=hegemon
pkgver=20181013.085336
-pkgrel=1
+pkgrel=2
pkgdesc='A modular system monitor written in Rust '
arch=('x86_64')
url='https://github.com/p-e-w/hegemon'
license=('GPL-3.0')
makedepends=('rust')
-depends=()
+depends=('lm_sensors')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
@@ -20,4 +20,4 @@ build() {
package() {
cd "$pkgname"
install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
-} \ No newline at end of file
+}