summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAttenuation2018-11-09 12:35:49 +0800
committerAttenuation2018-11-09 12:35:49 +0800
commited5ac3206334ed9a23ac8548abe540e09b557d23 (patch)
tree0b67228da74a92c5c70de6f61ccedfb0842db568
downloadaur-ed5ac3206334ed9a23ac8548abe540e09b557d23.tar.gz
add package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a40e052cf8f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hegemon
+ pkgdesc = A modular system monitor written in Rust
+ pkgver = 20181013.085336
+ pkgrel = 1
+ url = https://github.com/p-e-w/hegemon
+ arch = x86_64
+ license = GPL-3.0
+ makedepends = rust
+ source = hegemon::git+https://github.com/p-e-w/hegemon
+ sha256sums = SKIP
+
+pkgname = hegemon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..373da46a1b3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Attenuation <ouyangjun1999@gmail.com>
+pkgname=hegemon
+pkgver=20181013.085336
+pkgrel=1
+pkgdesc='A modular system monitor written in Rust '
+arch=('x86_64')
+url='https://github.com/p-e-w/hegemon'
+license=('GPL-3.0')
+makedepends=('rust')
+depends=()
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+} \ No newline at end of file