summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2019-10-31 16:17:45 +0100
committerfrederik2019-10-31 16:17:45 +0100
commit78836cf4ead6f5115cb762039780fae7bb099dce (patch)
tree0606cb8cd344fa1742318c55d349fda8e0209faa
parent2270de05f3d17f04d3bd40993098c87684f78ad6 (diff)
downloadaur-78836cf4ead6f5115cb762039780fae7bb099dce.tar.gz
heif: PKGBUILD review by svenstaro
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD21
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cf3ee930105..ce693190036e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = heif
arch = i686
license = custom
makedepends = cmake
+ depends = gcc-libs
source = https://github.com/nokiatech/heif/archive/v3.5.0.tar.gz
sha512sums = 504933aff12aee8898e9c51024131cbd2e77303f8fc8e01d42a5668b1f9bca10669e38b609cf42ccc9458427e3d7cc56abdff6cd6c1fa0e7ccbb1f196273e051
diff --git a/PKGBUILD b/PKGBUILD
index 919b005888cd..fa5272c949c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,22 @@ pkgdesc='High Efficiency Image File Format'
arch=('x86_64' 'i686')
url='https://nokiatech.github.io/heif/'
license=('custom')
+depends=('gcc-libs')
makedepends=('cmake')
source=("https://github.com/nokiatech/heif/archive/v${pkgver}.tar.gz")
sha512sums=('504933aff12aee8898e9c51024131cbd2e77303f8fc8e01d42a5668b1f9bca10669e38b609cf42ccc9458427e3d7cc56abdff6cd6c1fa0e7ccbb1f196273e051')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}/build/"
- cmake ../srcs
- make
+ cd ${pkgname}-${pkgver}/build/
+ cmake ../srcs
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- install -dm755 "${pkgdir}/usr/lib/heif/"
-
- install -Dm644 LICENSE.TXT "${pkgdir}/usr/share/licenses/${pkgname}"
- cp -r srcs/api "${pkgdir}/usr/lib/heif/"
-
- cd build/lib/
- install -Dm644 -t "${pkgdir}/usr/lib/" ./*
+ cd ${pkgname}-${pkgver}
+ install -dm755 "${pkgdir}"/usr/lib/heif/
+ install -Dm644 LICENSE.TXT "${pkgdir}"/usr/share/licenses/${pkgname}
+ cp -r srcs/api "${pkgdir}"/usr/lib/heif/
+ cd build/lib/
+ install -Dm644 -t "${pkgdir}"/usr/lib/ ./*
}