summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraiyion.prime2018-07-14 18:59:10 +0200
committeraiyion.prime2018-07-14 18:59:10 +0200
commitae371ffeb1b60551669480360f2b789b95c4b69f (patch)
treedb95ebd3d1ddfba631cac542723137669fcab0fa
downloadaur-ae371ffeb1b60551669480360f2b789b95c4b69f.tar.gz
long live heimdall
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd893fe85cf1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = heimdallr-git
+ pkgdesc = finding public ssh keys with ease
+ pkgver = r11.d79de45
+ pkgrel = 1
+ url = https://github.com/AiyionPrime/heimdallr
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = curl
+ depends = json-c
+ provides = heimdallr-git
+ conflicts = heimdallr
+ source = git+https://github.com/aiyionprime/heimdallr.git
+ md5sums = SKIP
+
+pkgname = heimdallr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f716de23440d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Aiyion <aur@aiyionpri.me>
+_pkgname=heimdallr
+pkgname=$_pkgname-git
+pkgver=r11.d79de45
+pkgrel=1
+pkgdesc="finding public ssh keys with ease"
+arch=('x86_64')
+url="https://github.com/AiyionPrime/heimdallr"
+license=('MIT')
+groups=()
+depends=('curl' 'json-c')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+provides=('heimdallr-git')
+conflicts=('heimdallr')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+https://github.com/aiyionprime/heimdallr.git)
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+