summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-02 11:54:33 -0500
committerLuis Martinez2021-10-02 11:54:33 -0500
commit5d3b0f3320870b28d6cc167232d871fff9297539 (patch)
treeccd32a97bcaa2a03f63e27776a4a949d3d7e6e45
parentd6fdf6ee6918243abc0b6289ccd4d6b86641f4e2 (diff)
downloadaur-5d3b0f3320870b28d6cc167232d871fff9297539.tar.gz
update to 2.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG19
-rw-r--r--PKGBUILD10
3 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b95e42b0c942..6d978c8c6364 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = heimer
- pkgdesc = A simple cross-platform mind map, diagram, and note-taking tool written in Qt
- pkgver = 2.6.0
+ pkgdesc = Cross-platform mind map, diagram, and note-taking tool written in Qt
+ pkgver = 2.7.0
pkgrel = 1
url = https://github.com/juzzlin/heimer
changelog = CHANGELOG
@@ -11,7 +11,7 @@ pkgbase = heimer
depends = gcc-libs
depends = hicolor-icon-theme
depends = qt5-svg
- source = heimer-2.6.0.tar.gz::https://github.com/juzzlin/heimer/archive/2.6.0.tar.gz
- sha256sums = 2d484facf1e3f8082145f94a30a65db661260aeec951c789647be0a895087dcb
+ source = heimer-2.7.0.tar.gz::https://github.com/juzzlin/heimer/archive/2.7.0.tar.gz
+ sha256sums = c1a59dd77ed2edfcd24ed46eb4828464f6563d3aac102878e2f2541e96481e3c
pkgname = heimer
diff --git a/CHANGELOG b/CHANGELOG
index 39bd997ce469..edd22991fcf2 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -7,6 +7,25 @@ Bug fixes:
Other:
+2.7.0
+=====
+
+New features:
+
+* Add Chinese translation
+
+* Add Spanish translation
+
+* Fix GitHub Issue #129: Add search field
+
+Bug fixes:
+
+* Fix editor scene getting broken when a file cannot be opened
+
+Other:
+
+* Limit application window startup size
+
2.6.0
=====
diff --git a/PKGBUILD b/PKGBUILD
index db49f06c4cd6..845da5e63915 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: davedatum <ask at davedatum dot com>
pkgname=heimer
-pkgver=2.6.0
+pkgver=2.7.0
pkgrel=1
-pkgdesc="A simple cross-platform mind map, diagram, and note-taking tool written in Qt"
+pkgdesc="Cross-platform mind map, diagram, and note-taking tool written in Qt"
arch=("x86_64")
url='https://github.com/juzzlin/heimer'
license=('GPL3')
depends=('gcc-libs' 'hicolor-icon-theme' 'qt5-svg')
makedepends=('cmake' 'qt5-tools')
changelog=CHANGELOG
-source=("${pkgname}-${pkgver}.tar.gz::$url/archive/${pkgver}.tar.gz")
-sha256sums=('2d484facf1e3f8082145f94a30a65db661260aeec951c789647be0a895087dcb')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('c1a59dd77ed2edfcd24ed46eb4828464f6563d3aac102878e2f2541e96481e3c')
build() {
cmake \