summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-12-25 23:26:48 -0600
committerLuis Martinez2021-12-25 23:26:48 -0600
commit8717e15018eed825813efc32c688c30267f6ee48 (patch)
tree91af17c37c460ee10198614ca382701ad8d49c08
parenta8c8130e2549918f72faf8af8bb4d8f1d1a2687c (diff)
downloadaur-8717e15018eed825813efc32c688c30267f6ee48.tar.gz
update to 3.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG34
-rw-r--r--PKGBUILD6
3 files changed, 37 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95c50df1f2f8..ad33a368b802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = heimer
pkgdesc = Cross-platform mind map, diagram, and note-taking tool written in Qt
- pkgver = 3.0.0
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/juzzlin/heimer
changelog = CHANGELOG
@@ -10,7 +10,7 @@ pkgbase = heimer
makedepends = qt5-tools
depends = hicolor-icon-theme
depends = qt5-svg
- source = heimer-3.0.0.tar.gz::https://github.com/juzzlin/heimer/archive/3.0.0.tar.gz
- sha256sums = f4bd37c9f92366546d3c4b278cbf38c2842617d8e980ce71248115181795f46b
+ source = heimer-3.1.0.tar.gz::https://github.com/juzzlin/heimer/archive/3.1.0.tar.gz
+ sha256sums = fe1331ba03a60e1ba6a8a8c42f281e109939a4eeb26632f84610a9a524397beb
pkgname = heimer
diff --git a/CHANGELOG b/CHANGELOG
index ae184f79a3a0..39220b6dc451 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,12 +1,42 @@
x.y.z
=====
+Release date:
+
+New features:
+
+Bug fixes:
+
+Other:
+
+3.1.0
+=====
+
+Release date:
+
+Fri, 24 Dec 2021 12:47:41 +0200
+
New features:
+* Option to automatically snap existing nodes to grid
+
+* Option for dashed lines in the edge context menu
+
Bug fixes:
+* Fix GitHub Issue #186: Icon is installed in /usr/share/icons/hicolor/64x64 but actual size is 256x256
+
+* Fix GitHub Issue #188: Double-clicking on a large node zooms in incorrectly
+
+* Fix GitHub Issue #189: Export to PNG breaks zoom out
+
+* Fix GitHub Issue #190: Export to PNG works only once
+ - Fixes the same issue with SVG export, too
+
Other:
+* Simplify edge context menu
+
3.0.0
=====
@@ -22,9 +52,7 @@ New features:
Bug fixes:
-* Fix autosave not triggering immediately on file operations
-
-Other:
+* Fix auto save not triggering immediately on file operations
2.8.0
=====
diff --git a/PKGBUILD b/PKGBUILD
index db603a9f2c6e..025039fa684f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: davedatum <ask at davedatum dot com>
pkgname=heimer
-pkgver=3.0.0
+pkgver=3.1.0
pkgrel=1
pkgdesc="Cross-platform mind map, diagram, and note-taking tool written in Qt"
arch=("x86_64")
@@ -13,7 +13,7 @@ depends=('hicolor-icon-theme' 'qt5-svg')
makedepends=('cmake' 'qt5-tools')
changelog=CHANGELOG
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('f4bd37c9f92366546d3c4b278cbf38c2842617d8e980ce71248115181795f46b')
+sha256sums=('fe1331ba03a60e1ba6a8a8c42f281e109939a4eeb26632f84610a9a524397beb')
build() {
cmake \
@@ -28,5 +28,5 @@ build() {
package() {
DESTDIR="$pkgdir/" make install -C build
cd "Heimer-$pkgver"
- install -Dm 644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
}