summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-12-13 20:30:54 -0800
committerxiota2023-12-13 20:30:54 -0800
commitc4a5343893a8715ad0157d5773120f313ec2c692 (patch)
treee16b5e0ef9aeaf12bff102d75ed786f7fd632c7a
parent01b9fce57e88d72cfe4cf0d37b59196e96b6d2ec (diff)
downloadaur-c4a5343893a8715ad0157d5773120f313ec2c692.tar.gz
4.3.0: reorganize
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD50
2 files changed, 37 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f43b8edcfc4..9d4a40ac8ede 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = heimer
pkgdesc = Cross-platform mind map, diagram, and note-taking tool written in Qt
- pkgver = 4.2.0
+ pkgver = 4.3.0
pkgrel = 1
url = https://github.com/juzzlin/heimer
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = heimer
makedepends = qt5-tools
depends = hicolor-icon-theme
depends = qt5-svg
- source = heimer-4.2.0.tar.gz::https://github.com/juzzlin/heimer/archive/4.2.0.tar.gz
- sha256sums = cbbc68c556845cb66a0bba0f1eab0bd6a0fb0d7f8bdd7e23984a45ab55b25ff5
+ source = heimer-4.3.0.tar.gz::https://github.com/juzzlin/heimer/archive/4.3.0.tar.gz
+ sha256sums = 6431955e85a10cde22399247d57c937db51afd84677dab200093992f00353436
pkgname = heimer
diff --git a/PKGBUILD b/PKGBUILD
index 2d08948aa240..85dfc3cb4a96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,51 @@
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: davedatum <ask at davedatum dot com>
+# options
+#: ${_pkgtype:=git}
+
+# basic info
_pkgname="heimer"
-pkgname="$_pkgname"
-pkgver=4.2.0
+pkgname="$_pkgname${_pkgtype:+-$_pkgtype}"
+pkgver=4.3.0
pkgrel=1
pkgdesc="Cross-platform mind map, diagram, and note-taking tool written in Qt"
url='https://github.com/juzzlin/heimer'
license=('GPL3')
arch=("x86_64")
-depends=(
- 'hicolor-icon-theme'
- 'qt5-svg'
- )
-makedepends=(
- 'cmake'
- 'qt5-tools'
- )
+# main package
+_main_package() {
+ depends=(
+ 'hicolor-icon-theme'
+ 'qt5-svg'
+ )
+ makedepends=(
+ 'cmake'
+ 'qt5-tools'
+ )
+ if [ "$pkgname" == "$_pkgname" ] ; then
+ _main_stable
+ else
+ _main_git
+ fi
+}
-if [ x"$pkgname" == x"$_pkgname" ] ; then
- # normal package
+# stable package
+_main_stable() {
_pkgsrc="Heimer-${pkgver%%.r*}"
_pkgext="tar.gz"
source=("$pkgname-${pkgver%%.r*}.$_pkgext"::"$url/archive/${pkgver%%.r*}.tar.gz")
- sha256sums=('cbbc68c556845cb66a0bba0f1eab0bd6a0fb0d7f8bdd7e23984a45ab55b25ff5')
+ sha256sums=('6431955e85a10cde22399247d57c937db51afd84677dab200093992f00353436')
pkgver() {
echo "${pkgver%%.r*}"
}
-else
- # git package
+}
+
+# git package
+_main_git() {
makedepends+=('git')
provides=("$_pkgname")
@@ -47,8 +61,9 @@ else
cd "$_pkgsrc"
git describe --long --tags --exclude='*[a-zA-Z][a-zA-Z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
-fi
+}
+# common functions
build() {
local _cmake_options=(
-S "$_pkgsrc"
@@ -71,3 +86,6 @@ package() {
install -Dvm644 "${srcdir:?}/$_pkgsrc/COPYING" -t "${pkgdir:?}/usr/share/licenses/$pkgname/"
}
+
+# execute
+_main_package