summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-02-22 06:32:58 +0800
committerzxp198210052023-02-22 06:32:58 +0800
commit43840cc19eee105148a84a3355b68b89ca483dd7 (patch)
tree62fd9ca93401ed5d5c4d64b61845cea9bf71d4d5
downloadaur-43840cc19eee105148a84a3355b68b89ca483dd7.tar.gz
first release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7c4275377dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = heimer-appimage
+ pkgdesc = Heimer is a simple cross-platform mind map, diagram, and note-taking tool written in Qt.
+ pkgver = 3.7.0
+ pkgrel = 1
+ url = https://github.com/juzzlin/Heimer
+ arch = x86_64
+ license = GPL3
+ depends = hicolor-icon-theme
+ depends = zlib
+ provides = heimer
+ conflicts = heimer
+ options = !strip
+ source = heimer-3.7.0.AppImage::https://github.com/juzzlin/Heimer/releases/download/3.7.0/Heimer-3.7.0-x86_64.AppImage
+ sha256sums = 8f2c8fafe8c6b413e6f2c456915097c690cbe83e6b67aad5b26ae7ab3a8c0344
+
+pkgname = heimer-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5401dab42b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=heimer-appimage
+_pkgname=heimer
+pkgver=3.7.0
+pkgrel=1
+epoch=
+pkgdesc="Heimer is a simple cross-platform mind map, diagram, and note-taking tool written in Qt."
+arch=("x86_64")
+url="https://github.com/juzzlin/Heimer"
+license=(GPL3)
+depends=(hicolor-icon-theme zlib)
+options=(!strip)
+optdepends=()
+provides=(heimer)
+conflicts=(heimer)
+install=
+_install_path="/opt/appimages"
+source=("${_pkgname}-${pkgver}.AppImage::${url}/releases/download/${pkgver}/Heimer-${pkgver}-x86_64.AppImage")
+sha256sums=('8f2c8fafe8c6b413e6f2c456915097c690cbe83e6b67aad5b26ae7ab3a8c0344')
+
+prepare() {
+ chmod a+x "${_pkgname}-${pkgver}.AppImage"
+ "./${_pkgname}-${pkgver}.AppImage" --appimage-extract
+ sed 's/Exec=heimer/Exec=\/opt\/appimages\/heimer.AppImage/g' -i "${srcdir}/squashfs-root/${_pkgname}.desktop"
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}-${pkgver}.AppImage" "${pkgdir}/${_install_path}/${_pkgname}.AppImage"
+ install -Dm644 "${srcdir}/squashfs-root/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "${srcdir}/squashfs-root/${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
+}