summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-11-20 05:18:25 +0100
committeraksr2015-11-20 05:18:25 +0100
commit5d379a98a1b78bc1e01d073bb3ef8e1b4512bf77 (patch)
tree3b01ccdad57c1fe02c222eeebffe1020874bc9f2
downloadaur-5d379a98a1b78bc1e01d073bb3ef8e1b4512bf77.tar.gz
Start.
-rw-r--r--.SRCINFO20
-rw-r--r--000-config.diff54
-rw-r--r--PKGBUILD43
3 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4da97766a47e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = heirloom-pkgtools-cvs
+ pkgdesc = The Heirloom Packaging Tools is a port of SVR4 application packaging utilities from OpenSolaris
+ pkgver = 111210
+ pkgrel = 4
+ url = http://heirloom.sourceforge.net/pkgtools.html
+ arch = i686
+ arch = x86_64
+ license = custom:CALDERA
+ license = custom:OPENSOLARIS
+ makedepends = cvs
+ depends = heirloom-sh-cvs
+ depends = heirloom-devtools-cvs
+ depends = heirloom-cvs
+ source = 000-config.diff
+ md5sums = 7ab977ec2bafe3b55fa9c56fe541e0d5
+ sha1sums = 2306f0f890c6cfcfba21a8ad0cc9d81872a1eb2d
+ sha256sums = c5dedd3c85b1d4cdee9d2c21a15b2bc042349da446e88c1a056881ce349674b7
+
+pkgname = heirloom-pkgtools-cvs
+
diff --git a/000-config.diff b/000-config.diff
new file mode 100644
index 000000000000..2c9b3c5df89a
--- /dev/null
+++ b/000-config.diff
@@ -0,0 +1,54 @@
+diff -ru heirloom-pkgtools-070227.orig/mk.config heirloom-pkgtools-070227/mk.config
+--- heirloom-pkgtools-070227.orig/mk.config 2007-02-27 16:13:42.000000000 -0400
++++ heirloom-pkgtools-070227/mk.config 2010-12-16 20:24:15.273333340 -0430
+@@ -2,36 +2,36 @@
+ # Path to the Heirloom Bourne shell. It is used during compilation
+ # as well as by the package commands.
+ #
+-SHELL = /sbin/sh
++SHELL = $(BINDIR)/sh
+
+ #
+ # A BSD-compatible install command.
+ #
+-INSTALL=/usr/ucb/install
++INSTALL=$(BINDIR)/ucb/install
+
+ #
+ # Where the Heirloom Development Tools package has been placed.
+ # $(CCSDIR)/bin must also be in the PATH setting when building.
+ #
+-CCSDIR=/usr/ccs
++CCSDIR=$(PREFIX)
+
+ #
+ # Prefixes.
+ #
+-PREFIX=/usr
++PREFIX=/usr/heirloom
+ VAR=/var
+
+ #
+ # Where to place binaries. This must be the same place
+ # where the Heirloom Toolchest binaries are installed.
+ #
+-BINDIR=$(PREFIX)/5bin
++BINDIR=$(PREFIX)/bin
+
+ #
+ # Where to place superuser-only binaries. This may be
+ # the same place as the binary directory.
+ #
+-SBINDIR=$(PREFIX)/5bin
++SBINDIR=$(BINDIR)
+
+
+ #
+ # Where to place the database of installed packages.
+ #
+-VSADMDIR=$(VAR)/sadm
++VSADMDIR=$(VAR)/lib/sadm
+
+
+ #
+ # Binaries are stripped with this command after installation.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..465dea8de786
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Contributor: Sascha Biermmanns <saschakb at gmail dot com>
+# Contributor: Jens Staal <staal1978@gmail.com>
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=heirloom-pkgtools-cvs
+pkgver=111210
+pkgrel=4
+arch=('i686' 'x86_64')
+pkgdesc="The Heirloom Packaging Tools is a port of SVR4 application packaging utilities from OpenSolaris"
+url="http://heirloom.sourceforge.net/pkgtools.html"
+license=('custom:CALDERA' 'custom:OPENSOLARIS')
+depends=('heirloom-sh-cvs' 'heirloom-devtools-cvs' 'heirloom-cvs')
+makedepends=('cvs')
+source=('000-config.diff')
+md5sums=('7ab977ec2bafe3b55fa9c56fe541e0d5')
+sha1sums=('2306f0f890c6cfcfba21a8ad0cc9d81872a1eb2d')
+sha256sums=('c5dedd3c85b1d4cdee9d2c21a15b2bc042349da446e88c1a056881ce349674b7')
+
+_hmake() {
+ env PATH="/usr/heirloom/bin:$PATH" MAKEFLAGS="" make "$@"
+}
+
+prepare() {
+ cvs -d:pserver:anonymous:@heirloom.cvs.sourceforge.net:/cvsroot/heirloom login
+ cvs -d:pserver:anonymous:@heirloom.cvs.sourceforge.net:/cvsroot/heirloom co -P heirloom-pkgtools
+ rm -rf $srcdir/build
+ cp -r $srcdir/heirloom-pkgtools $srcdir/build
+ cd $srcdir/build
+ patch -p1 < ../000-config.diff
+}
+
+build() {
+ cd "$srcdir/build"
+ make
+}
+
+package() {
+ cd $srcdir/build
+ make install ROOT=$pkgdir
+ cd "$srcdir/heirloom-pkgtools/LICENSE/"
+ install -Dm0644 CALDERA.LICENSE $pkgdir/usr/share/licenses/${pkgname}/CALDERA.LICENSE
+ install -m0644 OPENSOLARIS.LICENSE $pkgdir/usr/share/licenses/${pkgname}
+}
+