summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2015-08-29 23:13:44 +0300
committerMantas Mikulėnas2015-08-29 23:14:49 +0300
commit482cfbde22a26623aaf0050e5b404c2a332e3dab (patch)
treeb571df736b2baed530b10032b8e72e953cd6eb09
downloadaur-482cfbde22a26623aaf0050e5b404c2a332e3dab.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--000-config.diff32
-rw-r--r--PKGBUILD33
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9e03f30a252
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = heirloom-sh
+ pkgdesc = Traditional sh derived from OpenSolaris code
+ pkgver = 050706
+ pkgrel = 3
+ url = http://heirloom.sourceforge.net/sh.html
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = CDDL
+ conflicts = heirloom-sh-cvs
+ source = http://sourceforge.net/projects/heirloom/files/heirloom-sh/050706/heirloom-sh-050706.tar.bz2
+ source = 000-config.diff
+ md5sums = 9169d9b3b845cb63c598ea29b8d2dfa0
+ md5sums = 991b32bee780ce48685dfd4d39d41443
+
+pkgname = heirloom-sh
+
diff --git a/000-config.diff b/000-config.diff
new file mode 100644
index 000000000000..10f5e4dba0fe
--- /dev/null
+++ b/000-config.diff
@@ -0,0 +1,32 @@
+--- heirloom-sh/makefile.orig 2010-12-16 02:22:05.400000007 -0430
++++ heirloom-sh/makefile 2010-12-16 02:24:37.463333339 -0430
+@@ -1,3 +1,5 @@
++PREFIX=/usr/heirloom
++
+ #
+ # Root directory. Mainly useful for package building; leave empty for
+ # normal installation.
+@@ -7,12 +9,12 @@
+ #
+ # The destination directory for the "sh" and "jsh" binaries.
+ #
+-SV3BIN=/usr/5bin
++SV3BIN=$(PREFIX)/bin
+
+ #
+ # Location for manual pages (with man1 below).
+ #
+-MANDIR=/usr/share/man/5man
++MANDIR=$(PREFIX)/share/man
+
+ #
+ # Enable this definition if spell checking should be done for the
+@@ -23,7 +25,7 @@
+ #
+ # A BSD-compatible install command.
+ #
+-UCBINST=/usr/ucb/install
++UCBINST=install
+
+ #
+ # The strip command that is used at installation time.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2d5d6a672be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Daniel Leidisch <spam@leidisch.net>
+# Updated by: Jens Staal <staal1978@gmail.com>
+# $Id: PKGBUILD,v 1.12 2010/12/17 21:45:33 andres Exp $
+
+pkgname="heirloom-sh"
+pkgver=050706
+pkgrel=3
+pkgdesc="Traditional sh derived from OpenSolaris code"
+arch=('i686' 'x86_64')
+url="http://heirloom.sourceforge.net/sh.html"
+license=('BSD' 'CDDL')
+conflicts=("$pkgname-cvs")
+source=("http://sourceforge.net/projects/heirloom/files/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
+ '000-config.diff')
+md5sums=('9169d9b3b845cb63c598ea29b8d2dfa0'
+ '991b32bee780ce48685dfd4d39d41443')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < ../000-config.diff
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make install ROOT="$pkgdir"
+
+ install -Dm644 CALDERA.LICENSE \
+ "$pkgdir"/usr/share/licenses/"$pkgname"/CALDERA
+}