summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjapernilater2015-07-01 21:50:41 -0500
committerjapernilater2015-07-01 21:50:41 -0500
commitb349958404ade9125de834ce6576966ac8c02b9d (patch)
tree450e56925a4872e84efd88c846e61e7a84766914
downloadaur-heli-x6.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
-rw-r--r--heli-x68
-rwxr-xr-xheli-x6.desktop11
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a0eeb172735
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = heli-x6
+ pkgdesc = Latest Professional R/C helicopter flight simulator from Heli x
+ pkgver = 6.0.1614
+ pkgrel = 1
+ url = http://www.heli-x.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = imagemagick
+ depends = java-environment-common
+ depends = lib32-libxcursor
+ depends = lib32-libxrandr
+ depends = bash
+ depends = lib32-libxxf86vm
+ options = !strip
+ source = heli-x6
+ source = heli-x6.desktop
+ source = http://www.heli-x.info/1614/HELI-X6.tar.gz
+ md5sums = b6bc5595d0dd2b3715b5a78f3b58feda
+ md5sums = 1a42b994dee957dfd17e5db2f4cec098
+ md5sums = 9e0f57f74ce37f9a80013c0fb5de82bc
+
+pkgname = heli-x6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a649b4c9467a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jeff Youdontneedtoknow <jeffpublicjr at gmail dot com>
+pkgname=heli-x6
+pkgver=6.0.1614
+pkgrel=1
+pkgdesc="Latest Professional R/C helicopter flight simulator from Heli x"
+arch=("i686" "x86_64")
+url="http://www.heli-x.net/"
+license=('custom')
+depends=('java-environment-common' 'lib32-libxcursor' 'lib32-libxrandr' 'bash' 'lib32-libxxf86vm')
+makedepends=('imagemagick')
+source=('heli-x6' 'heli-x6.desktop' 'http://www.heli-x.info/1614/HELI-X6.tar.gz')
+md5sums=('b6bc5595d0dd2b3715b5a78f3b58feda'
+ '1a42b994dee957dfd17e5db2f4cec098'
+ '9e0f57f74ce37f9a80013c0fb5de82bc')
+
+options=(!strip)
+
+package() {
+ install -d -m755 $pkgdir/usr/share/
+ cp -R HELI-X6 $pkgdir/usr/share/$pkgname
+ install -d -m755 $pkgdir/usr/bin
+ install -m755 heli-x6 $pkgdir/usr/bin/$pkgname
+ install -d -m755 $pkgdir/usr/share/applications
+ install -d -m755 $pkgdir/usr/share/pixmaps
+ install -m755 $pkgname.desktop $pkgdir/usr/share/applications
+ convert $srcdir/HELI-X6/runHeli-X.ico runHELI-X-3.png
+ install -m755 $srcdir/runHELI-X-3-3.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -d -m755 $pkgdir/usr/share/licenses/$pkgname
+ install -m755 $srcdir/HELI-X6/libs/HeliX/license.txt $pkgdir/usr/share/licenses/$pkgname/license.text
+ install -m755 $srcdir/HELI-X6/libs/HeliX/license_e.txt $pkgdir/usr/share/licenses/$pkgname/license_e.text
+ }
+
+
diff --git a/heli-x6 b/heli-x6
new file mode 100644
index 000000000000..caab7385bd9e
--- /dev/null
+++ b/heli-x6
@@ -0,0 +1,8 @@
+#!/bin/sh
+unset WINEPREFIX
+if [ ! -d "$HOME"/.heli-x6 ] ; then
+ echo "Notice: Copying heli-x6 into ~/.heli-x6. To uninstall completely, don't forget to remove ~/.heli-x6."
+ mkdir "$HOME"/.heli-x6
+ rsync -av /usr/share/heli-x6/* "$HOME"/.heli-x6
+fi
+"$HOME"/.heli-x6/runHELI-X.sh
diff --git a/heli-x6.desktop b/heli-x6.desktop
new file mode 100755
index 000000000000..c232e64f184e
--- /dev/null
+++ b/heli-x6.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=6.0.1608
+Type=Application
+Name=Heli X6
+Comment=Professional R/C helicopter flight simulator
+Exec=/usr/bin/heli-x6
+Encoding=UTF-8
+Icon=/usr/share/pixmaps/heli-x6.png
+Categories=Game;
+Terminal=false
+StartupNotify=false