summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoep Kortekaas2020-01-28 16:04:37 +0100
committerYoep Kortekaas2020-01-28 16:04:37 +0100
commit6c5f1d8a38a273b804865a2145c001ca869a3ccc (patch)
tree42fda03c52b09451e1ccde5ef6ca3f66603304a1
downloadaur-6c5f1d8a38a273b804865a2145c001ca869a3ccc.tar.gz
Package build and src info for building HElib, a homomorphic encryption library, v1.0.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5eb54802bf7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = helib-git
+ pkgdesc = A software library that implements homomorphic encryption (HE) through the BGV scheme
+ pkgver = 1.0.0.beta1.Aug2019.r52.072ffc8
+ pkgrel = 1
+ url = https://homenc.github.io/HElib/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = cmake>=3.5.1
+ makedepends = make
+ makedepends = gcc>=5.4.0
+ makedepends = libpthread-stubs
+ makedepends = git
+ depends = gmp>=6.0.0
+ depends = ntl>=11.0.0
+ provides = helib
+ conflicts = helib
+ source = helib::git+https://github.com/homenc/HElib.git
+ md5sums = SKIP
+
+pkgname = helib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58cc93479580
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Yoep Kortekaas <yoep dot kortekaas at gmail dot com>
+pkgname=helib-git
+pkgver=1.0.0.beta1.Aug2019.r52.072ffc8
+pkgrel=1
+pkgdesc="A software library that implements homomorphic encryption (HE) through the BGV scheme"
+arch=('i686' 'x86_64')
+url="https://homenc.github.io/HElib/"
+license=('Apache')
+groups=()
+depends=('gmp>=6.0.0' 'ntl>=11.0.0')
+makedepends=('cmake>=3.5.1' 'make' 'gcc>=5.4.0' 'libpthread-stubs' 'git')
+provides=("helib")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('helib::git+https://github.com/homenc/HElib.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/build"
+ make DESTDIR="$pkgdir/" install
+}