summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormilkmiruku2018-01-24 12:28:47 +0000
committermilkmiruku2018-01-24 12:28:47 +0000
commit9dc9408e4cef268b14ca5115205e12cf27438e75 (patch)
treec06ef74297379d437c57f5c9cce756ed5f842888
parenta8519760fa9f44fbdea8525e3a79fd43f9e6e752 (diff)
downloadaur-9dc9408e4cef268b14ca5115205e12cf27438e75.tar.gz
Fresh PKGBUILD
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD75
2 files changed, 59 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e0f96c61fc7..f83f5ba5f9ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,30 @@
-# Generated by mksrcinfo v8
-# Thu May 11 09:57:42 UTC 2017
pkgbase = helio-workstation-git
- pkgdesc = Free and open source music sequencer
- pkgver = v1.7.r16.43d4dc6
- pkgrel = 3
+ pkgdesc = A high-performance MIDI sequencer with a clean interface, version control, VST support and more
+ pkgver = r308.f8e4225
+ pkgrel = 1
url = https://helioworkstation.com/
arch = x86_64
license = GPL3
makedepends = git
- depends = alsa-lib
+ depends = freetype2
+ depends = libx11
+ depends = libxinerama
+ depends = libxrandr
+ depends = libxcursor
+ depends = libxcomposite
+ depends = mesa
+ depends = freeglut
depends = curl
+ depends = alsa-lib
+ depends = jack
+ depends = asio
+ depends = steinberg-vst36
provides = helio-workstation
conflicts = helio-workstation
- source = helio-workstation::git+https://github.com/peterrudenko/helio-workstation.git
- source = JUCE::git+https://github.com/WeAreROLI/JUCE.git
+ source = git+https://github.com/helio-fm/helio-workstation.git
+ source = git+https://github.com/WeAreROLI/JUCE.git
+ source = git+https://github.com/greg7mdp/sparsepp.git
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index fe480f12537e..0c02bc56ac6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,53 @@
-# Maintainer: Moritz Kiefer <moritz.kiefer@purelyfunctional.org>
-pkgname=helio-workstation-git
-pkgver=v1.7.r16.43d4dc6
-pkgrel=3
-pkgdesc='Free and open source music sequencer'
+# Maintainer: Milk Brewster <aur@milkmiruku.com>
+
+_pkgname=helio-workstation
+pkgname="${_pkgname}-git"
+pkgver=r308.f8e4225
+pkgrel=1
+pkgdesc="A high-performance MIDI sequencer with a clean interface, version control, VST support and more"
arch=('x86_64')
-url='https://helioworkstation.com/'
+url="https://helioworkstation.com/"
license=('GPL3')
-depends=('alsa-lib' 'curl')
-makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+https://github.com/peterrudenko/helio-workstation.git"
- "JUCE::git+https://github.com/WeAreROLI/JUCE.git")
-md5sums=('SKIP'
- 'SKIP')
-noextract=()
+depends=('freetype2' 'libx11' 'libxinerama' 'libxrandr' 'libxcursor' 'libxcomposite' 'mesa' 'freeglut' 'curl'
+ 'alsa-lib' 'jack' 'asio' 'steinberg-vst36')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/helio-fm/helio-workstation.git"
+ "git+https://github.com/WeAreROLI/JUCE.git"
+ "git+https://github.com/greg7mdp/sparsepp.git")
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+
+ # Git, tags available
+ # printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${_pkgname}"
git submodule init
- git config submodule.ThirdParty/JUCE.url $srcdir/JUCE
+ git config submodule.JUCE.url "$srcdir"/ThirdParty/JUCE
+ git config submodule.sparsepp.url "$srcdir"/ThirdParty/SparseHashMap
git submodule update
- cd "$srcdir/${pkgname%-git}/ThirdParty/JUCE/extras/Projucer/Builds/LinuxMakefile"
- sed -i 's/\/\/#define\ JUCE_WEB_BROWSER/#define\ JUCE_WEB_BROWSER 0/g' ../../JuceLibraryCode/AppConfig.h
- sed -i 's/webkit2gtk-4.0//g' Makefile
-}
-
-pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+ cd "$srcdir/${_pkgname}/Projects/LinuxMakefile"
+ make check-pkg-config
}
build() {
- cd "$srcdir/${pkgname%-git}/ThirdParty/JUCE/extras/Projucer/Builds/LinuxMakefile"
- CONFIG=Release make
- ./build/Projucer --resave ./../../../../../../Projects/Projucer/Helio\ Workstation.jucer
- cd "$srcdir/${pkgname%-git}/Projects/LinuxMakefile"
- CONFIG=Release64 make
+ cd "$srcdir/${_pkgname}/Projects/LinuxMakefile"
+ export CONFIG=Release64
+ make
}
package() {
- cd "$srcdir/${pkgname%-git}/Projects/Installers/Linux/Helio-1.7-amd64/"
- cp -r usr "$pkgdir/usr"
- cd "$srcdir/${pkgname%-git}/Projects/LinuxMakefile/build"
- install -dm775 "$pkgdir/opt/helio_workstation/"
- install -m755 "Helio" "$pkgdir/opt/helio_workstation/helio_workstation"
+ cd "$srcdir/${_pkgname}/Projects/"
+ install -Dm755 "LinuxMakefile/build/Helio" "$pkgdir/opt/helio_workstation/helio_workstation"
+ install -Dm755 "Installers/Linux/Helio-1.7-amd64/usr/bin/helio" "$pkgdir/usr/bin/helio"
+ cp -r "Installers/Linux/Helio-1.7-amd64/usr/" "$pkgdir/"
}