summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2020-12-29 16:40:58 +0100
committerAndrea Feletto2020-12-29 16:40:58 +0100
commit0e3b28743868259b03f2de746c0f80f4c6afb58b (patch)
tree4337ffef23400ed806c65464f15f78e4c5788c93
parentb9f0472e91e116dc772f4eadd85623a1ca7a06f2 (diff)
downloadaur-0e3b28743868259b03f2de746c0f80f4c6afb58b.tar.gz
update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ddb0f546620..02d273368b49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = heliocron-bin
pkgdesc = Execute tasks relative to sunset, sunrise and other solar events.
- pkgver = 0.4.0
- pkgrel = 2
+ pkgver = 0.5.0
+ pkgrel = 1
url = https://github.com/mfreeborn/heliocron
arch = x86_64
license = Apache
license = MIT
provides = heliocron
conflicts = heliocron-git
- source = https://github.com/mfreeborn/heliocron/releases/download/v0.4.0/heliocron-v0.4.0-x86_64-unknown-linux-gnu.tar.gz
- sha256sums = 83cd3d97d0b32a624069f16a82991ad7ee01826ee9532d124cce6eff4aea6b0d
+ source = https://github.com/mfreeborn/heliocron/releases/download/v0.5.0/heliocron-v0.5.0-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = 1de3c5edb1ac3b143d63fdbee9da79e8f9d3fc481ebd1274747023d90385c2b1
pkgname = heliocron-bin
diff --git a/PKGBUILD b/PKGBUILD
index b7c1d1519997..85e8d34b3a46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
-# Heliocron
# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
pkgname=heliocron-bin
_pkgname=${pkgname%-*}
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.5.0
+pkgrel=1
pkgdesc='Execute tasks relative to sunset, sunrise and other solar events.'
arch=('x86_64')
url='https://github.com/mfreeborn/heliocron'
license=('Apache' 'MIT')
provides=('heliocron')
conflicts=('heliocron-git')
-source=(
- "https://github.com/mfreeborn/$_pkgname/releases/download/v$pkgver/$_pkgname-v$pkgver-x86_64-unknown-linux-gnu.tar.gz"
-)
-sha256sums=(
- '83cd3d97d0b32a624069f16a82991ad7ee01826ee9532d124cce6eff4aea6b0d'
-)
+source=("https://github.com/mfreeborn/$_pkgname/releases/download/v$pkgver/$_pkgname-v$pkgver-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=('1de3c5edb1ac3b143d63fdbee9da79e8f9d3fc481ebd1274747023d90385c2b1')
package() {
cd "$srcdir/$_pkgname-v$pkgver-x86_64-unknown-linux-gnu"
- install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 "$_pkgname" -t "$pkgdir/usr/bin"
+ install -Dm644 'LICENSE-APACHE' -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 'LICENSE-MIT' -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 'README.md' -t "$pkgdir/usr/share/doc/$_pkgname"
}