summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2020-07-27 14:52:18 +0200
committerAndrea Feletto2020-07-27 14:52:18 +0200
commitb9f0472e91e116dc772f4eadd85623a1ca7a06f2 (patch)
tree8bed65d3c9502d8fdd1cae5c7013d559c2d36150
parentd2fe0f2b6b468e68419313f70d7dc53e6f543fe3 (diff)
downloadaur-b9f0472e91e116dc772f4eadd85623a1ca7a06f2.tar.gz
better package function and added conflict with heliocron-git
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cc39c0a1216..1ddb0f546620 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = heliocron-bin
pkgdesc = Execute tasks relative to sunset, sunrise and other solar events.
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mfreeborn/heliocron
arch = x86_64
license = Apache
license = MIT
provides = heliocron
+ conflicts = heliocron-git
source = https://github.com/mfreeborn/heliocron/releases/download/v0.4.0/heliocron-v0.4.0-x86_64-unknown-linux-gnu.tar.gz
sha256sums = 83cd3d97d0b32a624069f16a82991ad7ee01826ee9532d124cce6eff4aea6b0d
diff --git a/PKGBUILD b/PKGBUILD
index 55e51d170a6a..b7c1d1519997 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,13 @@
pkgname=heliocron-bin
_pkgname=${pkgname%-*}
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='Execute tasks relative to sunset, sunrise and other solar events.'
arch=('x86_64')
url='https://github.com/mfreeborn/heliocron'
license=('Apache' 'MIT')
provides=('heliocron')
+conflicts=('heliocron-git')
source=(
"https://github.com/mfreeborn/$_pkgname/releases/download/v$pkgver/$_pkgname-v$pkgver-x86_64-unknown-linux-gnu.tar.gz"
)
@@ -19,8 +20,7 @@ sha256sums=(
)
package() {
- install -d "$pkgdir/usr/bin"
cd "$srcdir/$_pkgname-v$pkgver-x86_64-unknown-linux-gnu"
- mv "$_pkgname" "$pkgdir/usr/bin"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
}