summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Flemström2015-07-21 17:06:21 +0200
committerDavid Flemström2015-07-21 17:08:10 +0200
commitcd186b6f4fcfdfdbfccd8a364d727568f829826e (patch)
tree2117265b5cc0c8060797230b7b1d2835ce388b5d
downloadaur-cd186b6f4fcfdfdbfccd8a364d727568f829826e.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
-rw-r--r--helios-agent.service13
-rw-r--r--helios-master.service13
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05398db918e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = helios-git
+ pkgdesc = Spotify Helios - Docker container orchestration platform
+ pkgver = 0.8.420.r0.ga0381bc
+ pkgrel = 1
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = maven
+ depends = java-runtime
+ depends = zookeeper
+ source = helios-git::git+ssh://git@github.com/spotify/helios.git
+ source = helios-master.service
+ source = helios-agent.service
+ md5sums = SKIP
+ md5sums = 2aeb4f23cf3520abbffa230d50a96ce6
+ md5sums = a0f0cd98b3b3888aba00ff8436e22506
+
+pkgname = helios-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a74f95ed668
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: David Flemström <dflemstr@spotify.com>
+pkgname=helios-git
+pkgver=0.8.420.r0.ga0381bc
+pkgrel=1
+pkgdesc="Spotify Helios - Docker container orchestration platform"
+license=('Apache')
+
+arch=('any')
+depends=('java-runtime' 'zookeeper')
+makedepends=('git' 'maven')
+source=("$pkgname::git+ssh://git@github.com/spotify/helios.git"
+ 'helios-master.service'
+ 'helios-agent.service')
+md5sums=('SKIP'
+ '2aeb4f23cf3520abbffa230d50a96ce6'
+ 'a0f0cd98b3b3888aba00ff8436e22506')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ mvn clean package -Dmaven.test.skip -Dmaven.javadoc.skip
+}
+
+package() {
+ install -dm755 "$pkgdir/var/lib/helios-master"
+ install -dm755 "$pkgdir/var/lib/helios-agent"
+
+ install -Dm644 helios-master.service -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm644 helios-agent.service -t "$pkgdir/usr/lib/systemd/system"
+
+ cd "$pkgname"
+ install -Dm644 helios-services/target/helios-services-*-shaded.jar -t "$pkgdir/usr/share/helios/lib/services/"
+ install -Dm644 helios-tools/target/helios-tools-*-shaded.jar -t "$pkgdir/usr/share/helios/lib/tools/"
+ install -Dm755 bin/helios-agent -t "$pkgdir/usr/bin/"
+ install -Dm755 bin/helios-master -t "$pkgdir/usr/bin/"
+ install -Dm755 bin/helios -t "$pkgdir/usr/bin/"
+
+ install -Dm644 src/deb/helios-master/default "$pkgdir/etc/default/helios-master"
+ install -Dm644 src/deb/helios-agent/default "$pkgdir/etc/default/helios-agent"
+}
diff --git a/helios-agent.service b/helios-agent.service
new file mode 100644
index 000000000000..36b74690c1e8
--- /dev/null
+++ b/helios-agent.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Spotify Helios Agent
+Documentation=https://github.com/spotify/helios/tree/master/docs
+After=zookeeper.service docker.socket
+Requires=zookeeper.service docker.socket
+
+[Service]
+EnvironmentFile=/etc/default/helios-agent
+WorkingDirectory=/var/lib/helios-agent
+ExecStart=/usr/bin/helios-agent --zk-namespace helios --name %H
+
+[Install]
+WantedBy=multi-user.target
diff --git a/helios-master.service b/helios-master.service
new file mode 100644
index 000000000000..6a97c694943c
--- /dev/null
+++ b/helios-master.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Spotify Helios Master
+Documentation=https://github.com/spotify/helios/tree/master/docs
+After=zookeeper.service docker.socket
+Requires=zookeeper.service docker.socket
+
+[Service]
+EnvironmentFile=/etc/default/helios-master
+WorkingDirectory=/var/lib/helios-master
+ExecStart=/usr/bin/helios-master --zk-namespace helios --name %H
+
+[Install]
+WantedBy=multi-user.target