summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Kescher2024-01-29 22:07:56 +0100
committerJeremy Kescher2024-01-29 22:07:56 +0100
commit899e7975ef862bff08b9794d25c164e0cf5ac06e (patch)
treeb0aa65b18889d4920653d6f225b2a574a213ba3f
parent634813b39dc6f22bed53ff3afaf72262b703c5d2 (diff)
downloadaur-899e7975ef862bff08b9794d25c164e0cf5ac06e.tar.gz
v0.4.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--config.toml35
3 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5e7bf7a1445..ad28a3f554a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hellpot-bin
pkgdesc = An endless honeypot that sends bots to hell. (Bin version)
- pkgver = 0.3
+ pkgver = 0.4.1
pkgrel = 1
url = https://github.com/yunginnanet/HellPot
arch = i486
@@ -19,7 +19,7 @@ pkgbase = hellpot-bin
sha256sums = 0136fd65b73e678d12ddff09cd5f71bfea360787cf7955770fe95b64dabe8274
sha256sums = a370bd1f4f1caa1aa4777e3a6cb6c752f711721c9913e09c78a11d304bc53b37
sha256sums = d462d4a84021cb2ce0052ba6c46ad0ea6e7aab7a9459d048de892d8503a99aee
- sha256sums = 8da2c84ec00ff3fc09a468c5389bf9388d3ca59184acfe65f1976e17840371bf
+ sha256sums = 5663856679a38a69572683f9720c4a20aeaf3eb6a26f5ca067e23d4fcc2b28ac
source_i486 = hellpot::https://github.com/yunginnanet/HellPot/releases/download/v0.3/HellPot-0.3-linux-386
sha256sums_i486 = c74f19ad905881c58ee53a76ab1a26932f5af9a5705014c7cccbfed9bc8620bb
source_i586 = hellpot::https://github.com/yunginnanet/HellPot/releases/download/v0.3/HellPot-0.3-linux-386
@@ -29,6 +29,6 @@ pkgbase = hellpot-bin
source_pentium4 = hellpot::https://github.com/yunginnanet/HellPot/releases/download/v0.3/HellPot-0.3-linux-386
sha256sums_pentium4 = c74f19ad905881c58ee53a76ab1a26932f5af9a5705014c7cccbfed9bc8620bb
source_x86_64 = hellpot::https://github.com/yunginnanet/HellPot/releases/download/v0.3/HellPot-0.3-linux-amd64
- sha256sums_x86_64 = f840e95211907080f7ca339d0699cfcf95ec58f7ce060d843713950a64f7e466
+ sha256sums_x86_64 = c74f19ad905881c58ee53a76ab1a26932f5af9a5705014c7cccbfed9bc8620bb
pkgname = hellpot-bin
diff --git a/PKGBUILD b/PKGBUILD
index f6051534c3cf..821a74aa82c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeremy Kescher <jeremy@kescher.at>
pkgname=hellpot-bin
_targetname=hellpot
-pkgver=0.3
+pkgver=0.4.1
pkgrel=1
_srcname=HellPot-$pkgver
pkgdesc="An endless honeypot that sends bots to hell. (Bin version)"
@@ -25,12 +25,12 @@ backup=('etc/hellpot/config.toml')
sha256sums=('0136fd65b73e678d12ddff09cd5f71bfea360787cf7955770fe95b64dabe8274'
'a370bd1f4f1caa1aa4777e3a6cb6c752f711721c9913e09c78a11d304bc53b37'
'd462d4a84021cb2ce0052ba6c46ad0ea6e7aab7a9459d048de892d8503a99aee'
- '8da2c84ec00ff3fc09a468c5389bf9388d3ca59184acfe65f1976e17840371bf')
+ '5663856679a38a69572683f9720c4a20aeaf3eb6a26f5ca067e23d4fcc2b28ac')
sha256sums_i486=('c74f19ad905881c58ee53a76ab1a26932f5af9a5705014c7cccbfed9bc8620bb')
sha256sums_i586=('c74f19ad905881c58ee53a76ab1a26932f5af9a5705014c7cccbfed9bc8620bb')
sha256sums_i686=('c74f19ad905881c58ee53a76ab1a26932f5af9a5705014c7cccbfed9bc8620bb')
sha256sums_pentium4=('c74f19ad905881c58ee53a76ab1a26932f5af9a5705014c7cccbfed9bc8620bb')
-sha256sums_x86_64=('f840e95211907080f7ca339d0699cfcf95ec58f7ce060d843713950a64f7e466')
+sha256sums_x86_64=('c74f19ad905881c58ee53a76ab1a26932f5af9a5705014c7cccbfed9bc8620bb')
package() {
cd "$srcdir"
diff --git a/config.toml b/config.toml
index 643f818b9a97..f378ca92c045 100644
--- a/config.toml
+++ b/config.toml
@@ -1,21 +1,28 @@
-
[deception]
- server_name = "nginx"
+server_name = 'nginx'
[http]
- bind_addr = "127.0.0.1"
- bind_port = "8080"
- paths = ["wp-login.php","wp-login"]
- unix_socket_path = "/run/hellpot/socket"
- unix_socket_permissions = "0666"
- use_unix_socket = true
+bind_addr = '127.0.0.1'
+bind_port = '8080'
+real_ip_header = 'X-Real-IP'
+uagent_string_blacklist = ['Cloudflare-Traffic-Manager']
+unix_socket_path = '/run/hellpot/socket'
+unix_socket_permissions = '0666'
+use_unix_socket = true
+
+[http.router]
+catchall = false
+makerobots = true
+paths = ['wp-login.php', 'wp-login']
[logger]
- debug = false
- directory = "/var/log/hellpot/"
- nocolor = true
- use_date_filename = true
+debug = true
+directory = '/var/log/hellpot'
+docker_logging = false
+nocolor = false
+trace = false
+use_date_filename = true
[performance]
- max_workers = 256
- restrict_concurrency = false
+max_workers = 256
+restrict_concurrency = false