summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2015-07-12 17:33:49 +0200
committerChristopher Arndt2015-07-12 17:33:49 +0200
commit730238999a5d43082a8df2bca55925b824692755 (patch)
treeae24e95c3d3b4daad573fa9a23afeb69e70ded2a
parent7ce4a92f2138a3d8d41a8cbdd4b0b87db9a4f093 (diff)
downloadaur-730238999a5d43082a8df2bca55925b824692755.tar.gz
Include VST3 SDK in sources; add changelog
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--ChangeLog6
-rw-r--r--PKGBUILD26
4 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b28ef092e7a4..3b5e2d018ff3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
pkgbase = helm-git
pkgdesc = a cross-platform, polyphonic synthesizer LV2 and VST plugin
pkgver = 0.3.3.r958.0741c59
- pkgrel = 1
+ pkgrel = 2
url = http://tytel.org/helm/
+ changelog = ChangeLog
arch = i686
arch = x86_64
groups = lv2-plugins
groups = vst-plugins
license = GPL
makedepends = git
- makedepends = unzip
depends = alsa-lib
depends = mesa
depends = lv2
provides = helm
conflicts = helm
source = helm::git+https://github.com/mtytel/helm.git
+ source = http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip
md5sums = SKIP
+ md5sums = 1ac422ebb4aa2e86061278412c347b55
pkgname = helm-git
diff --git a/.gitignore b/.gitignore
index b166b492e239..f1cb312e894d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,5 @@ pkg
helm-git-*.tar.xz
helm-git-*.src.tar.gz
vst_sdk2.4_rev2.zip
+vstsdk360_22_11_2013_build_100.zip
.AURINFO
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..803d4b1b1b34
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,6 @@
+2015-07-12 Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+ * 0.3.3.r958.0741c59-2:
+ add VST3 SDK to sources, since it can be downloaded from Steinberg's
+ website now without login
+ removed 'unzip' from dependencies accordingly \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d727067fd92e..2a49f8dc88b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,26 @@
_pkgname=helm
pkgname="${_pkgname}-git"
pkgver=0.3.3.r958.0741c59
-pkgrel=1
+pkgrel=2
pkgdesc="a cross-platform, polyphonic synthesizer LV2 and VST plugin"
arch=('i686' 'x86_64')
url="http://tytel.org/helm/"
license=('GPL')
groups=('lv2-plugins' 'vst-plugins')
depends=('alsa-lib' 'mesa' 'lv2')
-makedepends=('git' 'unzip')
+makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/mtytel/helm.git")
-md5sums=('SKIP')
+source=("${_pkgname}::git+https://github.com/mtytel/helm.git"
+ 'http://www.steinberg.net/sdk_downloads/vstsdk360_22_11_2013_build_100.zip')
+md5sums=('SKIP'
+ '1ac422ebb4aa2e86061278412c347b55')
+changelog=ChangeLog
-prepare() {
- cd "${srcdir}"
-
- if [ ! -d vstsdk2.4 ]; then
-
- if [ ! -e "$startdir/vst_sdk2.4_rev2.zip" ]; then
- error "This package needs the Steinberg VST SDK 2.4rev2 to build."
- plain "Place the file vst_sdk2.4-rev2.zip next to PKGBUILD manually."
- fi
-
- unzip "$startdir/vst_sdk2.4_rev2.zip"
- fi
+prepare() {
cd "$srcdir/${_pkgname}/builds/linux/VST"
- sed -i -e "s|-I ~/srcs/vstsdk2.4|-I $srcdir/vstsdk2.4|" Makefile
+ sed -i -e "s|-I ~/srcs/VST3\\\\ SDK|-I $srcdir/VST3\\\\ SDK|" Makefile
}
pkgver() {