summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2020-05-27 20:59:54 +0200
committerMatthias Lisin2020-05-27 20:59:54 +0200
commitfed4b8711f0d2a70689fe1e1c88a8a67b7e67cb2 (patch)
treee0f32244261b3a1246cfbcf5bd8e2b532a13f5de
downloadaur-fed4b8711f0d2a70689fe1e1c88a8a67b7e67cb2.tar.gz
newpkg: helm-s3 0.9.2-1
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD43
-rw-r--r--helm-s3.install4
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93bf804a9255
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = helm-s3
+ pkgdesc = Helm plugin that allows to use AWS S3 as a [private] chart repository
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/hypnoglow/helm-s3
+ install = helm-s3.install
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = helm
+ source = helm-s3-0.9.2.tar.gz::https://github.com/hypnoglow/helm-s3/archive/v0.9.2.tar.gz
+ sha256sums = a601ebde9d881da832189fa4cf75e88a2c402fb5b1081e00e56bff3ee854b2e8
+
+pkgname = helm-s3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f1ecb611e6e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/src/
+/*.log
+/*.tar.gz
+/*.pkg.tar*
+/*.src.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c34a19795454
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: ml <ml@visu.li>
+pkgname=helm-s3
+pkgver=0.9.2
+pkgrel=1
+pkgdesc='Helm plugin that allows to use AWS S3 as a [private] chart repository'
+arch=('x86_64')
+url='https://github.com/hypnoglow/helm-s3'
+license=('MIT')
+install=helm-s3.install
+depends=('helm')
+makedepends=('go')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('a601ebde9d881da832189fa4cf75e88a2c402fb5b1081e00e56bff3ee854b2e8')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ go mod download
+ sed -i '/^hooks:$/Q' plugin.yaml
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export CGO_ENABLED=1
+ export CGO_LDFLAGS="$LDFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export GOFLAGS='-buildmode=pie -trimpath -modcacherw -mod=readonly'
+ go build -o bin/helms3 -ldflags "-X main.version=${pkgver}" ./cmd/helms3
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ make test-unit
+ grep -Fqm1 "$pkgver" bin/helms3
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 bin/helms3 -t "${pkgdir}/usr/lib/helm/plugins/${pkgname}/bin"
+ install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname}"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
diff --git a/helm-s3.install b/helm-s3.install
new file mode 100644
index 000000000000..6e6034c142c1
--- /dev/null
+++ b/helm-s3.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Run the following command to finish plugin installation:"
+ echo -e "\thelm plugin install /usr/lib/helm/plugins/helm-s3"
+}