summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2020-05-28 12:36:12 +0200
committerMatthias Lisin2020-05-28 12:36:12 +0200
commit4955c5df73f1fcc9a6885a00c2fa955dd1d305d4 (patch)
treefb3c755861faa1e5a9d682a45ac79364024fb021
parent1c9bfe3622a9eb11a58b857ecb6e2e899a83cb22 (diff)
downloadaur-4955c5df73f1fcc9a6885a00c2fa955dd1d305d4.tar.gz
upgpkg: helm-secrets 2.0.2-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--helm-secrets.install2
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34019f38d9e0..1bec1f005cac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = helm-secrets
pkgdesc = Helm plugin to manage secrets with Git workflow and store them anywhere
pkgver = 2.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zendesk/helm-secrets
install = helm-secrets.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 01ad1eca19ab..caa1bb61bc6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# TODO add test. update to HEAD
pkgname=helm-secrets
pkgver=2.0.2
-pkgrel=1
+pkgrel=2
pkgdesc='Helm plugin to manage secrets with Git workflow and store them anywhere'
arch=('any')
url='https://github.com/zendesk/helm-secrets'
@@ -24,6 +24,6 @@ package() {
cd "${pkgname}-${pkgver}"
# shell scripts don't belong in /usr/lib, but other plugins reside there as well.
# will fix later
- install -Dm755 secrets.sh -t "${pkgdir}/usr/lib/helm/plugins/${pkgname}"
- install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname}"
+ install -Dm755 secrets.sh -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
+ install -m644 plugin.yaml -t "${pkgdir}/usr/lib/helm/plugins/${pkgname##helm-}"
}
diff --git a/helm-secrets.install b/helm-secrets.install
index 216e934c88ac..847205062a79 100644
--- a/helm-secrets.install
+++ b/helm-secrets.install
@@ -1,4 +1,4 @@
post_install() {
echo "Run the following command to finish plugin installation:"
- echo -e "\thelm plugin install /usr/lib/helm/plugins/helm-secrets"
+ echo -e "\thelm plugin install /usr/lib/helm/plugins/secrets"
}