summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgato_lento2018-01-11 08:56:55 -0500
committergato_lento2018-01-11 08:56:55 -0500
commitd153bf886385430ced76706ff29a30b45bc1ded3 (patch)
tree28d81f00b368ca91a845c4e9124b09d5373876a8
downloadaur-d153bf886385430ced76706ff29a30b45bc1ded3.tar.gz
1st commit, split off from helm PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD48
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3e4aa549e12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = helm-vst
+ pkgdesc = a cross-platform, polyphonic synthesizer VST plugin
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = http://tytel.org/helm/
+ arch = x86_64
+ groups = vst-plugins
+ license = GPL
+ makedepends = steinberg-vst36
+ depends = alsa-lib
+ depends = freetype2
+ depends = mesa
+ source = https://github.com/mtytel/helm/archive/v0.9.0.tar.gz
+ sha256sums = 4004c11fd1d773cc2a12adb5336873bc86c5ecbd370b8da2820fed6ef5ec58ad
+
+pkgname = helm-vst
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6a94ad6eb7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: gato_lento <vukk.euob at gmail>
+# Based on helm-git PKGBUILD by: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname='helm-vst'
+_pkgname='helm'
+pkgver=0.9.0
+pkgrel=1
+pkgdesc='a cross-platform, polyphonic synthesizer VST plugin'
+arch=('x86_64')
+url='http://tytel.org/helm/'
+license=('GPL')
+groups=('vst-plugins')
+depends=('alsa-lib' 'freetype2' 'mesa')
+makedepends=('steinberg-vst36')
+source=("https://github.com/mtytel/helm/archive/v${pkgver}.tar.gz")
+sha256sums=('4004c11fd1d773cc2a12adb5336873bc86c5ecbd370b8da2820fed6ef5ec58ad')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ msg2 "Fixing Makefiles..."
+ sed -i -e "s|-I ~/srcs/VST3\\\\ SDK||" \
+ builds/linux/VST/Makefile
+
+ msg2 "Fixing VST3 SDK include paths in JUCE sources..."
+ for file in \
+ JUCE/extras/Projucer/Source/Utility/jucer_StoredSettings.cpp \
+ JUCE/modules/juce_audio_plugin_client/VST/juce_VST_Wrapper.cpp \
+ JUCE/modules/juce_audio_processors/format_types/juce_VST3Headers.h; do
+ sed -i -e 's|public.sdk/source/vst2.x|vst36|g' "$file"
+ done
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND -Wno-error"
+ make vst
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ CXXFLAGS="${CXXFLAGS} -DHAVE_LROUND -Wno-error"
+ make DESTDIR="$pkgdir" install_patches
+ install -D builds/linux/VST/build/helm.so "${pkgdir}/usr/lib/vst/helm.so"
+ mv ${pkgdir}/usr/share/helm{,-vst}
+}