summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Geraskin2020-10-23 14:20:29 +0300
committerRoman Geraskin2020-10-23 14:23:24 +0300
commit5889f402090bfa603e4ee2a5443bb43cfe0968ca (patch)
treead5d2c1018b1c3679b35f34d380baec29fc1c931
downloadaur-5889f402090bfa603e4ee2a5443bb43cfe0968ca.tar.gz
initial: helmenv 0.2.3
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c3d0c8e2166
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = helmenv-bin
+ pkgdesc = Helm version manager inspired by tfenv
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/little-angry-clouds/kubernetes-binaries-managers
+ arch = x86_64
+ license = GPL3
+ provides = helmenv
+ provides = helm
+ conflicts = helm
+ source = helmenv-bin-0.2.3.tar.gz::https://github.com/little-angry-clouds/kubernetes-binaries-managers/releases/download/0.2.3/helmenv-linux-amd64.tar.gz
+ sha256sums = 820510e6c01cccf2e50ec82280dd14d2e4b29e75002dc590a1ef0ef78a3c5a20
+
+pkgname = helmenv-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..020f79f76a95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.zst
+*.tar.gz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6fcc3736ba5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Roman Geraskin <roman dot n dot geraskin at gmail dot com>
+
+pkgname=helmenv-bin
+_pkgname="${pkgname%-bin}"
+pkgver=0.2.3
+pkgrel=1
+pkgdesc='Helm version manager inspired by tfenv'
+arch=('x86_64')
+_goos='linux'
+_goarch='amd64'
+url='https://github.com/little-angry-clouds/kubernetes-binaries-managers'
+license=('GPL3')
+provides=("$_pkgname" "helm")
+conflicts=("helm")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/little-angry-clouds/kubernetes-binaries-managers/releases/download/$pkgver/$_pkgname-$_goos-$_goarch.tar.gz")
+sha256sums=(820510e6c01cccf2e50ec82280dd14d2e4b29e75002dc590a1ef0ef78a3c5a20)
+
+package() {
+ install -Dm 755 $_pkgname-$_goos-$_goarch "$pkgdir/usr/bin/$_pkgname"
+ install -Dm 755 helm-wrapper-$_goos-$_goarch "$pkgdir/usr/bin/helm"
+} \ No newline at end of file