summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Domingo Cansino2020-01-30 16:56:27 +0000
committerJavier Domingo Cansino2020-01-30 16:57:42 +0000
commit27a88ff69021118fba2b670619dc0322a7316b8f (patch)
treec5e671329ff55952c9cfb2d7092aa3c27daa670d
parent03a05cff86b757381bcef54628d1c6c975561a08 (diff)
downloadaur-27a88ff69021118fba2b670619dc0322a7316b8f.tar.gz
Upgrade helmsman to v3.0.2
-rw-r--r--.SRCINFO6
-rw-r--r--.pre-commit-config.yaml13
-rw-r--r--PKGBUILD4
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c51a2b5ff6e..1872e8f7d3f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = helmsman-bin
pkgdesc = Helmsman binary distribution
- pkgver = 1.9.1
+ pkgver = 3.0.2
pkgrel = 1
url = https://github.com/Praqma/helmsman
arch = x86_64
license = MIT
provides = helmsman
conflicts = helmsman
- source = https://github.com/Praqma/helmsman/releases/download/v1.9.1/Helmsman_1.9.1_linux_amd64.tar.gz
- sha256sums = d6717dfc002953209ffc86d666387f1473c46b60387685dbf5ec8e9a0bf5503b
+ source = https://github.com/Praqma/helmsman/releases/download/v3.0.2/Helmsman_3.0.2_linux_amd64.tar.gz
+ sha256sums = 206641e94741fc373f81bc38ebd6d196e6a4fca4c2aca6f0f2c5548da3ab08da
pkgname = helmsman-bin
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..543b6cd6f7ee
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,13 @@
+- repo: local
+ hooks:
+ - id: updpkgsums
+ name: updpkgsums
+ entry: updpkgsums
+ language: system
+ files: PKGBUILD
+ - id: makepkg
+ name: makepkg
+ entry: makepkg --printsrcinfo > .SRCINFO
+ language: system
+ files: PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
index 788d8b11f37a..f73afebe3a5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=helmsman-bin
-pkgver=1.9.1
+pkgver=3.0.2
pkgrel=1
pkgdesc="Helmsman binary distribution"
arch=('x86_64')
@@ -9,7 +9,7 @@ provides=('helmsman')
conflicts=('helmsman')
source=("https://github.com/Praqma/helmsman/releases/download/v${pkgver//_/-}/Helmsman_${pkgver//_/-}_linux_amd64.tar.gz"
)
-sha256sums=('d6717dfc002953209ffc86d666387f1473c46b60387685dbf5ec8e9a0bf5503b')
+sha256sums=('206641e94741fc373f81bc38ebd6d196e6a4fca4c2aca6f0f2c5548da3ab08da')
package() {
install -d "$pkgdir/usr/bin/"