summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2021-03-14 00:33:48 +0100
committerEmmanuel Gil Peyrot2021-03-14 00:33:48 +0100
commit9e934f485e8dca7bab5db144cce75b5c0ecaae55 (patch)
treeebe18c4f37a5dddd27e2e5c35464cad556748e92
downloadaur-9e934f485e8dca7bab5db144cce75b5c0ecaae55.tar.gz
Hello world!
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad19e8e7c717
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = helvum-git
+ pkgdesc = GTK-based patchbay for pipewire, inspired by the JACK tool catia
+ pkgver = 0.1.0.r10.gb348339
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/ryuukyu/helvum
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = rust
+ depends = gtk4
+ depends = pipewire
+ provides = helvum
+ conflicts = helvum
+ source = git+https://gitlab.freedesktop.org/ryuukyu/helvum.git
+ sha256sums = SKIP
+
+pkgname = helvum-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2730ffa45a54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgname=helvum-git
+pkgver=0.1.0.r10.gb348339
+pkgrel=1
+pkgdesc='GTK-based patchbay for pipewire, inspired by the JACK tool catia'
+arch=('x86_64' 'aarch64')
+url='https://gitlab.freedesktop.org/ryuukyu/helvum'
+license=('GPL3')
+depends=('gtk4' 'pipewire')
+makedepends=('git' 'rust')
+provides=('helvum')
+conflicts=('helvum')
+source=('git+https://gitlab.freedesktop.org/ryuukyu/helvum.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd helvum
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd helvum
+
+ cargo update
+ cargo build \
+ --release
+}
+
+package() {
+ cd helvum
+
+ cargo install \
+ --root "$pkgdir/usr" \
+ --path "$srcdir/helvum"
+}