summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmitayas Banerjee2022-09-09 13:35:54 +0530
committerAmitayas Banerjee2022-09-09 13:35:54 +0530
commitf8d71d48d9099613e1282678602095113bc25eb8 (patch)
treeedc6f01e4bf33608608ff5500067e2511d64e42d
parentac5589df98951f53f1ec043d0aa112c17c3d6ec9 (diff)
downloadaur-f8d71d48d9099613e1282678602095113bc25eb8.tar.gz
use meson to build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 146956be3826..b4c7ece99c47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,17 +2,18 @@ pkgbase = helvum-git
pkgdesc = GTK-based patchbay for pipewire, inspired by the JACK tool catia
pkgver = 0.3.2.115.gc1ec56e
pkgrel = 1
- url = https://gitlab.freedesktop.org/ryuukyu/helvum
+ url = https://gitlab.freedesktop.org/pipewire/helvum.git
arch = x86_64
arch = aarch64
license = GPL3
makedepends = git
makedepends = rust
+ makedepends = meson
depends = gtk4
depends = pipewire
provides = helvum
conflicts = helvum
- source = git+https://gitlab.freedesktop.org/ryuukyu/helvum.git
+ source = git+https://gitlab.freedesktop.org/pipewire/helvum.git
sha256sums = SKIP
pkgname = helvum-git
diff --git a/PKGBUILD b/PKGBUILD
index 24e5b1f1952f..94ff828908ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,24 +7,22 @@ arch=('i686' 'x86_64')
url="https://gitlab.freedesktop.org/ryuukyu/helvum"
license=('GPL3')
depends=('pipewire' 'gtk4')
-makedepends=('rust' 'cargo' 'git')
+makedepends=('rust' 'cargo' 'git' 'meson')
provides=('helvum')
conflicts=('helvum')
-source=("$_pkgname::git+https://gitlab.freedesktop.org/ryuukyu/helvum.git")
+source=("$_pkgname::git+https://gitlab.freedesktop.org/pipewire/helvum.git")
sha384sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- echo "$(grep '^version =' Cargo.toml | head -n1 | awk -F '"' '{print $2}').$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+ cd "$_pkgname"
+ echo "$(grep '^version =' Cargo.toml | head -n1 | awk -F '"' '{print $2}').$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cd $_pkgname
- RUSTUP_TOOLCHAIN=stable cargo build --release --locked --all-features --target-dir=target
- }
+ meson --prefix=/usr --buildtype=plain "$pkgname-$pkgver" build
+ meson compile -C build
+}
package() {
- cd "$srcdir/$_pkgname"
- install -Dm 755 target/release/${_pkgname} -t "${pkgdir}/usr/bin"
- install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ meson install -C build --destdir "$pkgdir"
}