summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKodi Craft2022-03-08 14:49:22 +0100
committerKodi Craft2022-03-08 14:49:22 +0100
commit95b1866105fe066306009b35187a7258c9a39a5c (patch)
tree4460748c3f51a67920b3c65f40c7d2eaf1744219
parent7f316eb962dcbb7da86769e2733e59f53a1828d6 (diff)
downloadaur-95b1866105fe066306009b35187a7258c9a39a5c.tar.gz
I swear I'm trying
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84ba737ec040..8dd80344de4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hentai.js
pkgdesc = rule34.xxx wrapper written in electron
pkgver = 2.3.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/KodiCraft/hentai.js
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index e39ada0fed7f..2c9c4c0036a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,14 +31,16 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- echo $(pwd)
- npm run make-linux
+
}
package() {
cd "$pkgname-$pkgver"
- echo $pkgdir
- mkdir "$pkgdir/opt/$pkgname"
- cp -Rf out/hentaijs-linux-x64/* "$pkgdir/opt/$pkgname"
- cp -Rf out/hentaijs-linux-x64/* /usr/bin/
+ npm run make-linux
+
+ mkdir -p "$pkgdir/usr/local/lib/hentaijs"
+ cp -r "out/hentaijs-linux-x64/" "$pkgdir/usr/local/lib/hentaijs/"
+ chmod 755 -R "$pkgdir/usr/local/lib/hentaijs/"
+ mkdir -p "$pkgdir/usr/local/bin/"
+ ln -s "$pkgdir/usr/local/lib/hentaijs/hentaijs-linux-x64/hentaijs" "$pkgdir/usr/local/bin/hentai.js"
}