summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKodi Craft2022-02-28 17:47:54 +0100
committerKodi Craft2022-02-28 17:47:54 +0100
commitf7f34e26b7ee935c1fc678d9ef2dbfe27deaaa20 (patch)
tree80173753c62e531d3bc6249adbf8ba87d9656ead
downloadaur-f7f34e26b7ee935c1fc678d9ef2dbfe27deaaa20.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84ba737ec040
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hentai.js
+ pkgdesc = rule34.xxx wrapper written in electron
+ pkgver = 2.3.6
+ pkgrel = 1
+ url = https://github.com/KodiCraft/hentai.js
+ arch = x86_64
+ license = MIT
+ depends = nodejs
+ depends = npm
+ optdepends = electron
+ source = https://github.com/KodiCraft/hentai.js/archive/refs/tags/v2.3.6.tar.gz
+ md5sums = SKIP
+
+pkgname = hentai.js
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64bfc295711d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Kodi <kodicraft4@gmail.com>
+pkgname=hentai.js
+pkgver=2.3.6
+pkgrel=1
+
+pkgdesc="rule34.xxx wrapper written in electron"
+arch=('x86_64')
+url="https://github.com/KodiCraft/hentai.js"
+license=('MIT')
+
+depends=("nodejs" "npm")
+makedepends=()
+checkdepends=()
+optdepends=("electron")
+# provides=()
+# conflicts=()
+# replaces=()
+# backup=()
+# options=()
+# install=
+# changelog=
+source=("$url/archive/refs/tags/v${pkgver}.tar.gz")
+# noextract=()
+md5sums=("SKIP")
+# validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ npm install --cache "${srcdir}/npm-cache"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ echo $(pwd)
+ npm run make-linux
+}
+
+package() {
+ echo "idk what to put here"
+ # mkdir /usr/bin/hentaijs
+ # cd out/hentaijs-linux-x64
+ # mv * /usr/bin/hentaijs
+ # ln -s /usr/bin/hentaijs/hentaijs /usr/bin/hentai.js
+}