summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2021-04-16 18:31:13 +0800
committerCoelacanthus2021-04-16 18:31:13 +0800
commitf0ed39c42fa069a3a4c2428238e75267efa12ef0 (patch)
tree22e86ecb195ebc35d43c4f50fd6fefd391ae84ef
parente6bf7f4011da229b65d7d5a08657829851afbab9 (diff)
downloadaur-f0ed39c42fa069a3a4c2428238e75267efa12ef0.tar.gz
upgpkg: hentaiathome 1.6.1-1
upstream release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
-rw-r--r--hentaiathome-gui.sh3
-rw-r--r--hentaiathome.INSTALL4
-rwxr-xr-xhentaiathome.desktop12
-rw-r--r--hentaiathome.pngbin0 -> 3915 bytes
-rw-r--r--hentaiathome.service11
7 files changed, 53 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2657ee991f9c..55260e60a0de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = hentaiathome
- pkgdesc = an open-source Peer-2-Peer gallery distribution system which reduces the load on the E-Hentai Galleries
- pkgver = 1.6.0
+ pkgdesc = An open-source Peer-2-Peer gallery distribution system which reduces the load on the E-Hentai Galleries
+ pkgver = 1.6.1
pkgrel = 1
url = https://ehwiki.org/wiki/Hentai@Home
- install = .INSTALL
+ install = hentaiathome.INSTALL
arch = x86_64
license = GPL3
provides = hentaiathome-bin
- source = hentaiathome-1.6.0.zip::https://repo.e-hentai.org/hath/HentaiAtHome_1.6.0.zip
+ source = hentaiathome-1.6.1.zip::https://repo.e-hentai.org/hath/HentaiAtHome_1.6.1.zip
source = hentaiathome.sh
- source = hentaiathomegui.sh
+ source = hentaiathome-gui.sh
+ source = hentaiathome.service
+ source = hentaiathome.desktop
source = hentaiathome.png::https://ehwiki.org/images/e/ef/H%40Hicon.png
- sha256sums = 597f0ae2d114a86e021013b0146d59b1f2f8be2025bfae6b38c181515b795018
+ sha256sums = b8889b2c35593004be061064fcb6d690ff8cbda9564d89f706f7e3ceaf828726
sha256sums = 6067fe31e5cdb9e05df2218f4761b7630d834725316099ed74609c86b11fe101
sha256sums = 49b8165512b981e73260b82686ed0c4004b626de1dcaa59039675e6ddc9041a4
+ sha256sums = b3ddd3425c34c6872a471ed94b53a52ba77896aa2cc4295ead35f2e3728214d1
+ sha256sums = f44c49afe7637b5bfbabd1c7fdee2c35acc2bb8e1d42a517c5c9a66715c0ac4e
sha256sums = 2f3461521c2eb9d5ee2d964169b2f502758b7679bef70ffe5d0dcfd04ecd7d97
pkgname = hentaiathome-cli
diff --git a/PKGBUILD b/PKGBUILD
index 4021344923cd..3bd17974c5e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,28 @@
-# Maintainer: yjun <jerrysteve1101@gmail.com>
+# Maintainer: Coelacanthus <coelacanthus@outlook.com.com>
+# Contributor: yjun <jerrysteve1101@gmail.com>
pkgbase=hentaiathome
pkgname=('hentaiathome-cli' 'hentaiathome-gui')
_pkgname=HentaiAtHome
-pkgver=1.6.0
+pkgver=1.6.1
pkgrel=1
-pkgdesc="an open-source Peer-2-Peer gallery distribution system which reduces the load on the E-Hentai Galleries"
+pkgdesc="An open-source Peer-2-Peer gallery distribution system which reduces the load on the E-Hentai Galleries"
arch=('x86_64')
url="https://ehwiki.org/wiki/Hentai@Home"
license=('GPL3')
provides=('hentaiathome-bin')
-install='.INSTALL'
+install="${pkgbase}.INSTALL"
source=("${pkgbase}-${pkgver}.zip::https://repo.e-hentai.org/hath/${_pkgname}_${pkgver}.zip"
"${pkgbase}.sh"
- "${pkgbase}gui.sh"
+ "${pkgbase}-gui.sh"
+ "${pkgbase}.service"
+ "${pkgbase}.desktop"
"${pkgbase}.png::https://ehwiki.org/images/e/ef/H%40Hicon.png")
-sha256sums=('597f0ae2d114a86e021013b0146d59b1f2f8be2025bfae6b38c181515b795018'
+sha256sums=('b8889b2c35593004be061064fcb6d690ff8cbda9564d89f706f7e3ceaf828726'
'6067fe31e5cdb9e05df2218f4761b7630d834725316099ed74609c86b11fe101'
'49b8165512b981e73260b82686ed0c4004b626de1dcaa59039675e6ddc9041a4'
+ 'b3ddd3425c34c6872a471ed94b53a52ba77896aa2cc4295ead35f2e3728214d1'
+ 'f44c49afe7637b5bfbabd1c7fdee2c35acc2bb8e1d42a517c5c9a66715c0ac4e'
'2f3461521c2eb9d5ee2d964169b2f502758b7679bef70ffe5d0dcfd04ecd7d97')
package_hentaiathome-cli() {
@@ -27,25 +32,13 @@ package_hentaiathome-cli() {
install -Dm 755 "${pkgbase}.sh" ${pkgdir}/usr/bin/${pkgbase}
install -dm 755 "${pkgdir}/usr/lib/systemd/system"
- cat > ${pkgdir}/usr/lib/systemd/system/hentaiathome.service << EOF
-[Unit]
-Description=Hentai At Home
-After=network-online.target
-
-[Service]
-Type=simple
-WorkingDirectory=/var/lib/${_username}
-ExecStart=/usr/bin/${pkgbase}
-
-[Install]
-WantedBy=multi-user.target
-EOF
+ install -Dm 755 "${pkgbase}.service" ${pkgdir}/usr/lib/systemd/system/hentaiathome.service
}
package_hentaiathome-gui() {
depends=('java-runtime>=8' 'hentaiathome-cli')
install -Dm 644 "${_pkgname}GUI.jar" ${pkgdir}/usr/share/java/${pkgbase}/${_pkgname}GUI.jar
- install -Dm 755 "${pkgbase}gui.sh" ${pkgdir}/usr/bin/${pkgbase}gui
+ install -Dm 755 "${pkgbase}-gui.sh" ${pkgdir}/usr/bin/${pkgbase}-gui
install -Dm 644 "${pkgbase}.png" ${pkgdir}/usr/share/pixmaps/${pkgbase}.png
}
diff --git a/hentaiathome-gui.sh b/hentaiathome-gui.sh
new file mode 100644
index 000000000000..c486d20b16ed
--- /dev/null
+++ b/hentaiathome-gui.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd /var/lib/hath && exec java -jar /usr/share/java/hentaiathome/HentaiAtHomeGUI.jar "$@"
diff --git a/hentaiathome.INSTALL b/hentaiathome.INSTALL
new file mode 100644
index 000000000000..9c2ebb185173
--- /dev/null
+++ b/hentaiathome.INSTALL
@@ -0,0 +1,4 @@
+post_install() {
+ mkdir -p var/lib/hath
+ ln -fs /usr/share/java/hentaiathome/HentaiAtHome.jar var/lib/hath/HentaiAtHome.jar
+}
diff --git a/hentaiathome.desktop b/hentaiathome.desktop
new file mode 100755
index 000000000000..12372d67881b
--- /dev/null
+++ b/hentaiathome.desktop
@@ -0,0 +1,12 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Name=Hentai@Home
+Type=Application
+GenericName=An open-source Peer-2-Peer gallery distribution system which reduces the load on the E-Hentai Galleries
+Comment=An open-source Peer-2-Peer gallery distribution system which reduces the load on the E-Hentai Galleries
+Keywords=Hentai;
+Categories=Utility;
+Terminal=false
+Exec=/usr/bin/hentaiathome-gui
+Icon=hentaiathome
diff --git a/hentaiathome.png b/hentaiathome.png
new file mode 100644
index 000000000000..2129c291c2e5
--- /dev/null
+++ b/hentaiathome.png
Binary files differ
diff --git a/hentaiathome.service b/hentaiathome.service
new file mode 100644
index 000000000000..911cc199ce3f
--- /dev/null
+++ b/hentaiathome.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Hentai At Home
+After=network-online.target
+
+[Service]
+Type=simple
+WorkingDirectory=/var/lib/${_username}
+ExecStart=/usr/bin/${pkgbase}
+
+[Install]
+WantedBy=multi-user.target