summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2020-04-16 10:16:43 +0200
committerFrank Siegert2020-04-16 10:17:26 +0200
commit4a300dd15a110e02ff988f563681e63f146cefb6 (patch)
tree6890b1b32b218e419ed5b118dec3a13c6f1000ae
parent345e1161fecd1636e752251cb376a45759850390 (diff)
downloadaur-4a300dd15a110e02ff988f563681e63f146cefb6.tar.gz
Update to 3.2.1-2
Re-enable search module and include patch for its compilation with gcc 9.3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63058dc837dc..58c6c8f18518 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hepmc3
pkgdesc = A particle physics package for storing collision events from Monte Carlo generators.
pkgver = 3.2.1
- pkgrel = 1
+ pkgrel = 2
url = http://hepmc.web.cern.ch/hepmc/
arch = x86_64
arch = i686
@@ -9,7 +9,9 @@ pkgbase = hepmc3
makedepends = cmake
optdepends = root: ROOT I/O support
source = https://hepmc.web.cern.ch/hepmc/releases/HepMC3-3.2.1.tar.gz
+ source = https://gitlab.cern.ch/hepmc/HepMC3/-/commit/ba38f14d8f56c16cc4105d98f6d4540c928c6150.diff
md5sums = 8cc6cc4f13fdf8be9ed677924daea250
+ md5sums = d8635566838595ff7d5884f0294bb960
pkgname = hepmc3
diff --git a/PKGBUILD b/PKGBUILD
index 199bb06357e3..810887bce4e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=hepmc3
pkgver=3.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A particle physics package for storing collision events from Monte Carlo generators."
arch=('x86_64' 'i686')
url="http://hepmc.web.cern.ch/hepmc/"
license=('GPL3')
makedepends=('cmake')
optdepends=('root: ROOT I/O support')
-source=("https://hepmc.web.cern.ch/hepmc/releases/HepMC3-${pkgver}.tar.gz")
+source=("https://hepmc.web.cern.ch/hepmc/releases/HepMC3-${pkgver}.tar.gz" "https://gitlab.cern.ch/hepmc/HepMC3/-/commit/ba38f14d8f56c16cc4105d98f6d4540c928c6150.diff")
noextract=()
-md5sums=('8cc6cc4f13fdf8be9ed677924daea250')
+md5sums=('8cc6cc4f13fdf8be9ed677924daea250'
+ 'd8635566838595ff7d5884f0294bb960')
build() {
cd "$srcdir/HepMC3-$pkgver"
+ patch -p1 < ../ba38f14d8f56c16cc4105d98f6d4540c928c6150.diff
mkdir -p build
cd build
- cmake ../ -DROOT_DIR=/usr -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DHEPMC3_ENABLE_SEARCH=OFF
+ cmake ../ -DROOT_DIR=/usr -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
make
}