summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLancia2022-10-26 21:11:18 +0330
committerLancia2022-10-26 21:11:18 +0330
commit7c2c7a94426f31f0d8f31326fbab67ae52d2d09b (patch)
tree93a5c1bdfcdeca23dc6183fb4d7b3491dfb295da
parent440a2cdfae70823a0cfb044e458f8353fc6ca2e1 (diff)
downloadaur-7c2c7a94426f31f0d8f31326fbab67ae52d2d09b.tar.gz
Corrected dependency and added an install command for the license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 395b3a1fbc3c..34d10f2adb96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = herbe
arch = x86_64
license = MIT
makedepends = make
- depends = libx11
+ depends = libxft
conflicts = herbe
conflicts = herbe-git
source = herbe-1.0.0.tar.gz::https://github.com/dudik/herbe/archive/1.0.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 86fa63d08350..17014fbe34be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgdesc='Daemon-less notifications without D-Bus'
arch=('x86_64')
url='https://github.com/dudik/herbe'
license=('MIT')
-depends=('libx11')
+depends=('libxft')
makedepends=('make')
conflicts=('herbe' 'herbe-git')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dudik/${pkgname}/archive/${pkgver}.tar.gz")
@@ -20,4 +20,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
make PREFIX='/usr' DESTDIR="$pkgdir/" install
+ install -D -m 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}