aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli W. Hunter2020-08-09 19:21:16 -0400
committerGitHub2020-08-09 19:21:16 -0400
commit2a640cffbffa923edc6c03a95d8f236db663cf4d (patch)
tree726a3028806d4163903107f90b0d9a26aa20b10e
parent831253836845a335f5f8fc30977f7eb127f329de (diff)
parentb4e31c4ea11930d28779f4dc33126ef1df735860 (diff)
downloadaur-2a640cffbffa923edc6c03a95d8f236db663cf4d.tar.gz
Merge pull request #1 from m-col/master
Include labours script
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b89a80f4f70..62e46bdbf82b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,11 @@
pkgname=hercules-analysis-git
pkgver=10.7.2.r4.g13a2081
pkgrel=1
-depends=('go' 'protobuf')
-makedepends=('make' 'git')
+depends=('go' 'protobuf'
+ 'python-matplotlib' 'python-scipy' 'python-pandas' 'python-yaml' 'python-protobuf'
+ 'python-munch' 'python-hdbscan' 'python-seriate' 'python-fastdtw' 'python-dateutil'
+ 'python-lifelines' 'python-tqdm')
+makedepends=('make' 'git' 'python-setuptools')
pkgdesc='Gaining advanced insights from Git repository history.'
arch=('any')
license=('Apache')
@@ -23,9 +26,13 @@ pkgver() {
build() {
cd "${srcdir}/hercules"
make
+ cd "${srcdir}/hercules/python"
+ python setup.py build
}
package() {
cd "${srcdir}/hercules"
install -Dm755 hercules "${pkgdir}/usr/bin/hercules"
+ cd "${srcdir}/hercules/python"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
}