aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli W. Hunter2020-08-09 19:25:11 -0400
committerEli W. Hunter2020-08-09 19:26:27 -0400
commit30b34d4605d32518b97505d37f2889d18d7682bb (patch)
tree5ffc8c92af064cf57f8b9660b8daa21b96f41a8b
parent2a640cffbffa923edc6c03a95d8f236db663cf4d (diff)
downloadaur-30b34d4605d32518b97505d37f2889d18d7682bb.tar.gz
Make protobuf and go makedepends
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD7
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f08b1a287082..86395d86b2a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,23 @@ pkgbase = hercules-analysis-git
url = https://github.com/src-d/hercules
arch = any
license = Apache
+ makedepends = go
+ makedepends = protobuf
makedepends = make
makedepends = git
- depends = go
- depends = protobuf
+ makedepends = python-setuptools
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-yaml
+ depends = python-protobuf
+ depends = python-munch
+ depends = python-hdbscan
+ depends = python-seriate
+ depends = python-fastdtw
+ depends = python-dateutil
+ depends = python-lifelines
+ depends = python-tqdm
source = git+https://github.com/src-d/hercules.git
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 9e344622167f..5f007e443913 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,3 +6,4 @@ src/
# git source code
hercules/
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 62e46bdbf82b..c76af90affc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,12 @@
pkgname=hercules-analysis-git
pkgver=10.7.2.r4.g13a2081
pkgrel=1
-depends=('go' 'protobuf'
+depends=(
'python-matplotlib' 'python-scipy' 'python-pandas' 'python-yaml' 'python-protobuf'
'python-munch' 'python-hdbscan' 'python-seriate' 'python-fastdtw' 'python-dateutil'
- 'python-lifelines' 'python-tqdm')
-makedepends=('make' 'git' 'python-setuptools')
+ 'python-lifelines' 'python-tqdm'
+)
+makedepends=('go' 'protobuf' 'make' 'git' 'python-setuptools')
pkgdesc='Gaining advanced insights from Git repository history.'
arch=('any')
license=('Apache')