aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcol2020-07-24 22:32:49 +0100
committermcol2020-07-24 22:32:49 +0100
commit8008648c4a44e5b04b346795c2b65ccff3ff0c4d (patch)
tree508d76e1fc2f16896d99f1f50a0bfc99375006a6
parent831253836845a335f5f8fc30977f7eb127f329de (diff)
downloadaur-8008648c4a44e5b04b346795c2b65ccff3ff0c4d.tar.gz
Include labours script and its dependencies as optdeps
-rw-r--r--PKGBUILD20
1 files changed, 19 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b89a80f4f70..29ea54c69b89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,27 @@ pkgname=hercules-analysis-git
pkgver=10.7.2.r4.g13a2081
pkgrel=1
depends=('go' 'protobuf')
-makedepends=('make' 'git')
+makedepends=('make' 'git' 'python-setuptools')
pkgdesc='Gaining advanced insights from Git repository history.'
arch=('any')
license=('Apache')
source=('git+https://github.com/src-d/hercules.git')
sha256sums=('SKIP')
url='https://github.com/src-d/hercules'
+optdepends=(
+ 'python-matplotlib: to use the labours python script'
+ 'python-scipy: to use the labours python script'
+ 'python-pandas: to use the labours python script'
+ 'python-yaml: to use the labours python script'
+ 'python-protobuf: to use the labours python script'
+ 'python-munch: to use the labours python script'
+ 'python-hdbscan: to use the labours python script'
+ 'python-seriate: to use the labours python script'
+ 'python-fastdtw: to use the labours python script'
+ 'python-dateutil: to use the labours python script'
+ 'python-lifelines: to use the labours python script'
+ 'python-tqdm: to use the labours python script'
+)
pkgver() {
cd "${srcdir}/hercules"
@@ -23,9 +37,13 @@ pkgver() {
build() {
cd "${srcdir}/hercules"
make
+ cd "${srcdir}/hercules/python"
+ python setup.py build
}
package() {
cd "${srcdir}/hercules"
install -Dm755 hercules "${pkgdir}/usr/bin/hercules"
+ cd "${srcdir}/hercules/python"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
}