aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcol2020-07-26 15:30:33 +0100
committermcol2020-07-26 15:30:33 +0100
commitb4e31c4ea11930d28779f4dc33126ef1df735860 (patch)
tree726a3028806d4163903107f90b0d9a26aa20b10e
parent8008648c4a44e5b04b346795c2b65ccff3ff0c4d (diff)
downloadaur-b4e31c4ea11930d28779f4dc33126ef1df735860.tar.gz
move deps for labours to depends from optdepends
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29ea54c69b89..62e46bdbf82b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,10 @@
pkgname=hercules-analysis-git
pkgver=10.7.2.r4.g13a2081
pkgrel=1
-depends=('go' 'protobuf')
+depends=('go' 'protobuf'
+ 'python-matplotlib' 'python-scipy' 'python-pandas' 'python-yaml' 'python-protobuf'
+ 'python-munch' 'python-hdbscan' 'python-seriate' 'python-fastdtw' 'python-dateutil'
+ 'python-lifelines' 'python-tqdm')
makedepends=('make' 'git' 'python-setuptools')
pkgdesc='Gaining advanced insights from Git repository history.'
arch=('any')
@@ -14,20 +17,6 @@ license=('Apache')
source=('git+https://github.com/src-d/hercules.git')
sha256sums=('SKIP')
url='https://github.com/src-d/hercules'
-optdepends=(
- 'python-matplotlib: to use the labours python script'
- 'python-scipy: to use the labours python script'
- 'python-pandas: to use the labours python script'
- 'python-yaml: to use the labours python script'
- 'python-protobuf: to use the labours python script'
- 'python-munch: to use the labours python script'
- 'python-hdbscan: to use the labours python script'
- 'python-seriate: to use the labours python script'
- 'python-fastdtw: to use the labours python script'
- 'python-dateutil: to use the labours python script'
- 'python-lifelines: to use the labours python script'
- 'python-tqdm: to use the labours python script'
-)
pkgver() {
cd "${srcdir}/hercules"