aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli W. Hunter2020-03-07 19:14:29 -0500
committerEli W. Hunter2020-03-07 19:21:39 -0500
commitbd565cee5051703a469678dbc6f10735e74a9386 (patch)
treea237f07851ecc8f5c0f8874a28e66bf4c57d3069
downloadaur-bd565cee5051703a469678dbc6f10735e74a9386.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD32
-rw-r--r--README.md13
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f08b1a287082
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hercules-analysis-git
+ pkgdesc = Gaining advanced insights from Git repository history.
+ pkgver = 10.7.2.r4.g13a2081
+ pkgrel = 1
+ url = https://github.com/src-d/hercules
+ arch = any
+ license = Apache
+ makedepends = make
+ makedepends = git
+ depends = go
+ depends = protobuf
+ source = git+https://github.com/src-d/hercules.git
+ sha256sums = SKIP
+
+pkgname = hercules-analysis-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9e344622167f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Generic PKGBUILD files
+*.pkg.tar.xz
+*.tar.gz
+pkg/
+src/
+
+# git source code
+hercules/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ca4b5d851f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Eli W. Hunter <elihunter173@gmail.com>
+
+# This PKGBUILD is maintained on github:
+# https://github.com/elihunter173/aur-hercules-git
+
+pkgname=hercules-analysis-git
+pkgver=10.7.2.r4.g13a2081
+pkgrel=1
+depends=('go' 'protobuf')
+makedepends=('make' 'git')
+pkgdesc='Gaining advanced insights from Git repository history.'
+arch=('any')
+license=('Apache')
+source=('git+https://github.com/src-d/hercules.git')
+sha256sums=('SKIP')
+url='https://github.com/src-d/hercules'
+
+pkgver() {
+ cd "${srcdir}/hercules"
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/hercules"
+ mkdir -p "${srcdir}/go"
+ GOPATH="${srcdir}/go" make
+}
+
+package() {
+ cd "${srcdir}/hercules"
+ install -Dm755 hercules "${pkgdir}/usr/bin/hercules"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..9d7e7fa91e32
--- /dev/null
+++ b/README.md
@@ -0,0 +1,13 @@
+# Hercules PKGBUILD
+
+A PKGBUILD for [Hercules](https://github.com/src-d/hercules).
+
+## Installation
+
+This can be installed from the AUR using your favorite AUR wrapper or manually
+by cloning the repository and running the following commands.
+
+```sh
+$ makepkg
+$ pacman -U pkgname-pkgver.pkg.tar.xz
+```