summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathaniel R. Lewis2017-09-15 11:24:11 -0700
committerNathaniel R. Lewis2017-09-15 11:24:11 -0700
commitfbc28f4101ba9e836c24494f78b6189c1d4807fa (patch)
tree9e3a7931df596c8cfe3c9c6e950a8674641d86c3
downloadaur-fbc28f4101ba9e836c24494f78b6189c1d4807fa.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
-rw-r--r--create-installation-paths.patch34
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94376a070245
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = herdtools7-git
+ pkgdesc = The Herd toolsuite to deal with .cat memory models
+ pkgver = r742.f2bb279
+ pkgrel = 1
+ url = https://github.com/herd/herdtools7
+ arch = i686
+ arch = x86_64
+ license = CeCILL-B
+ makedepends = git
+ makedepends = make
+ makedepends = ocamlbuild
+ depends = ocaml
+ provides = herdtools7
+ conflicts = herdtools7
+ source = git://github.com/herd/herdtools7
+ source = create-installation-paths.patch
+ sha256sums = SKIP
+ sha256sums = a7b8c376201196064835fba0d646bee567fe2932900772045a75b6bdd2a9a2ff
+
+pkgname = herdtools7-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c63fe19f454
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Nathaniel R. Lewis <linux.robotdude@gmail.com>
+
+_pkgbase='herdtools7'
+pkgname=('herdtools7-git')
+provides=('herdtools7')
+conflicts=('herdtools7')
+pkgver=r742.f2bb279
+pkgrel=1
+pkgdesc="The Herd toolsuite to deal with .cat memory models"
+arch=('i686' 'x86_64')
+url='https://github.com/herd/herdtools7'
+license=('CeCILL-B')
+depends=('ocaml')
+makedepends=('git' 'make' 'ocamlbuild')
+source=('git://github.com/herd/herdtools7'
+ 'create-installation-paths.patch')
+sha256sums=('SKIP'
+ 'a7b8c376201196064835fba0d646bee567fe2932900772045a75b6bdd2a9a2ff')
+
+prepare() {
+ cd $srcdir/$_pkgbase
+ git apply ../create-installation-paths.patch
+}
+
+build() {
+ cd $srcdir/$_pkgbase
+ make $MAKEFLAGS PREFIX="/usr"
+}
+
+pkgver() {
+ cd $srcdir/$_pkgbase
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ make -C $srcdir/$_pkgbase PREFIX="$pkgdir/usr" install
+}
+
diff --git a/create-installation-paths.patch b/create-installation-paths.patch
new file mode 100644
index 000000000000..e4df5b5e5aa0
--- /dev/null
+++ b/create-installation-paths.patch
@@ -0,0 +1,34 @@
+From f1feb0d630b2c74d9623959da5aa946a078dde31 Mon Sep 17 00:00:00 2001
+From: Patrick McLean <chutzpah@gentoo.org>
+Date: Fri, 15 Sep 2017 10:35:10 -0700
+Subject: [PATCH] install.sh: make installation directories before trying to
+ copy files to them
+
+---
+ install.sh | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/install.sh b/install.sh
+index 72f6163..e84c645 100755
+--- a/install.sh
++++ b/install.sh
+@@ -17,6 +17,16 @@ fi
+ BINDIR=$PREFIX/bin
+ LIBDIR=$PREFIX/share/herdtools7
+
++if ! [ -d $BINDIR ]
++then
++ mkdir -p $BINDIR
++fi
++
++if ! [ -d $LIBDIR ]
++then
++ mkdir -p $LIBDIR
++fi
++
+ cpbin () {
+ SUB=$1
+ EXECS="$2"
+--
+2.14.1
+