summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-01-05 14:43:34 +0100
committerCarl Smedstad2024-01-05 14:43:34 +0100
commite64e6ef77382aacd78d9b46520227ebf8ec42b62 (patch)
treed78be4a0fca025614e6f2d27338a95d24744534b
parentbe168093a9947009039c9cefff50413a3b51f350 (diff)
downloadaur-e64e6ef77382aacd78d9b46520227ebf8ec42b62.tar.gz
Publish version 0.25.1-5
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59a61fe7fc92..5eb1a145fba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hererocks
pkgdesc = Tool for installing Lua and LuaRocks locally
pkgver = 0.25.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/luarocks/hererocks
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index cfafc670888a..0975b6d022b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=hererocks
pkgver=0.25.1
-pkgrel=4
+pkgrel=5
pkgdesc="Tool for installing Lua and LuaRocks locally"
arch=(any)
url="https://github.com/luarocks/hererocks"
@@ -18,9 +18,7 @@ makedepends=(
python-setuptools
python-wheel
)
-checkdepends=(
- python-pytest
-)
+checkdepends=(python-pytest)
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
sha256sums=('bd3769fb9f7ac944f67601575a6c0aad7118e89ebba418985a126c2412f1f9e0')
@@ -36,11 +34,11 @@ build() {
check() {
cd "$_archive"
- python -m pytest -k " \
- not test_install_latest_lua_with_latest_luarocks \
- and not test_install_latest_lua_with_luarocks_from_git \
- and not test_install_lua_5_1_without_compat_without_readline_with_old_luarocks \
- "
+ python -m pytest \
+ --deselect test/cli_test.py::TestCLI::test_install_latest_lua_with_latest_luarocks \
+ --deselect test/cli_test.py::TestCLI::test_install_latest_lua_with_luarocks_from_git \
+ --deselect test/cli_test.py::TestCLI::test_install_lua_5_1_without_compat_without_readline_with_old_luarocks \
+ --deselect test/cli_test.py::TestCLI::test_verbose_install_bleeding_edge_luajit_with_latest_luarocks
}
package() {
@@ -48,5 +46,5 @@ package() {
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}