summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian MARGAINE2015-12-27 23:23:44 +0100
committerFlorian MARGAINE2015-12-27 23:23:44 +0100
commite88d4852724aa182cd4ff78082e1e6228258f1c5 (patch)
tree64c19cdf5c46e9435b070d2285c51cd865b1bb98
downloadaur-e88d4852724aa182cd4ff78082e1e6228258f1c5.tar.gz
1.8
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD24
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2679407296ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 22:23:30 UTC 2015
+pkgbase = hermes
+ pkgdesc = Authenticate on linux by plugging your USB stick!
+ pkgver = 1.8
+ pkgrel = 1
+ url = https://github.com/ralt/hermes
+ arch = x86_64
+ license = MIT
+ makedepends = sbcl
+ makedepends = wget
+ makedepends = buildapp
+ makedepends = libfixposix
+ makedepends = pam
+ depends = pam
+ depends = libfixposix
+ options = !strip
+ source = https://github.com/ralt/hermes/archive/1.8.tar.gz
+ md5sums = 9d3029dfb700ea51ab1f304971835f78
+
+pkgname = hermes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..925d3e667144
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Florian Margaine <florian at margaine dot com>
+pkgname=hermes
+pkgver=1.8
+pkgrel=1
+pkgdesc="Authenticate on linux by plugging your USB stick!"
+arch=(x86_64)
+url="https://github.com/ralt/hermes"
+license=('MIT')
+depends=(pam libfixposix)
+makedepends=(sbcl wget buildapp libfixposix pam)
+options=(!strip)
+install=
+source=("https://github.com/ralt/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('9d3029dfb700ea51ab1f304971835f78')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}