summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSampson Crowley2020-09-03 22:31:58 -0600
committerSampson Crowley2020-09-03 22:31:58 -0600
commit043d8f9a9f71c60770b6ee24a129e0d398016221 (patch)
tree156dd99a01b5f57af223a03503b947fc51a46d36
parent1a4aa3f37de3e69331fdd8123c1e54213bdd5318 (diff)
downloadaur-043d8f9a9f71c60770b6ee24a129e0d398016221.tar.gz
upgpkg: heroku-cli 7.42.13-2
rebuild heroku-cli process
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD54
3 files changed, 52 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a44758b4433..35f979098279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,26 @@
pkgbase = heroku-cli
pkgdesc = a tool for creating and managing Heroku apps from the command line
pkgver = 7.42.13
- pkgrel = 1
+ pkgrel = 2
url = https://devcenter.heroku.com/articles/heroku-cli
arch = x86_64
+ arch = armv7h
license = custom
license = ISC
- makedepends = npm
depends = nodejs
optdepends = git: Deploying to Heroku
+ provides = heroku
+ provides = heroku-cli
conflicts = heroku-client-standalone
conflicts = heroku-toolbelt
conflicts = ruby-heroku
- noextract = heroku-7.42.13.tgz
options = !strip
- source = https://registry.npmjs.org/heroku/-/heroku-7.42.13.tgz
- sha256sums = 7a11fa94bceabb8d9110983e67195fc376843e23e7c0efdff609d6b77684d618
- sha512sums = a9806111a982775fb150324d6b4bf26ba7d4ebe8e7e8433274c57df6e6090b5e80da1bddd81818a2e86a1cf5964c8453ad26107015f43c591308a1137ac7c877
+ source_x86_64 = https://storage.googleapis.com/arch-package-files/heroku-v7.42.13-linux-x64.tar.xz
+ sha256sums_x86_64 = 9313870e71d8a6737a6cf5d7f4c94a350128db97ec8648b90e8f2d53bda9e92b
+ sha512sums_x86_64 = bf2945f3faed1ae54bc51407782e3288d7024808acb4e0be0a7b55e0b61b99f4a4b8be7a66d9d97584d5994f23a39f7a6df8079ec71f8ee1dfd2feec8b7dab3c
+ source_armv7h = https://storage.googleapis.com/arch-package-files/heroku-v7.42.13-linux-arm.tar.xz
+ sha256sums_armv7h = decfbc9e407cf3e965907cc134610b72e7a67972ba57f3bbe28178c84686f539
+ sha512sums_armv7h = 51cdcf09d04a8854eb6b9ee301a1e67d87d6e9b881c2f7672a7e7fe491beb63e8ac73b5736ebb81a457e8a5f9bc6c4a8f34711c53217df86037f5cb03b7f8058
pkgname = heroku-cli
diff --git a/.gitignore b/.gitignore
index b3de4fbfbbd2..0afd27b13605 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
heroku-*.tgz
src/
pkg
+cli-source
*.pkg.tar*
+*linux*.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6eef90e2e0d4..8e9382b40fc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,55 @@
pkgname=heroku-cli
pkgver=7.42.13
_builddir=cli-${pkgver}
-pkgrel=1
+pkgrel=2
pkgdesc="a tool for creating and managing Heroku apps from the command line"
-arch=('x86_64')
+arch=('x86_64' 'armv7h')
url="https://devcenter.heroku.com/articles/heroku-cli"
license=('custom' 'ISC')
depends=('nodejs')
-makedepends=('npm')
+# makedepends=('npm')
optdepends=('git: Deploying to Heroku')
conflicts=('heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
-source=("https://registry.npmjs.org/heroku/-/heroku-$pkgver.tgz")
-sha256sums=('7a11fa94bceabb8d9110983e67195fc376843e23e7c0efdff609d6b77684d618')
-sha512sums=('a9806111a982775fb150324d6b4bf26ba7d4ebe8e7e8433274c57df6e6090b5e80da1bddd81818a2e86a1cf5964c8453ad26107015f43c591308a1137ac7c877')
-noextract=("heroku-$pkgver.tgz")
+# source=("https://cli-assets.heroku.com/heroku-v$pkgver/heroku-v$pkgver-linux-x86.tar.xz")
+# source_armv7h=("https://cli-assets.heroku.com/heroku-v$pkgver/heroku-v$pkgver-linux-arm.tar.xz")
+source_x86_64=("https://storage.googleapis.com/arch-package-files/heroku-v$pkgver-linux-x64.tar.xz")
+source_armv7h=("https://storage.googleapis.com/arch-package-files/heroku-v$pkgver-linux-arm.tar.xz")
+sha256sums_x86_64=('9313870e71d8a6737a6cf5d7f4c94a350128db97ec8648b90e8f2d53bda9e92b')
+sha256sums_armv7h=('decfbc9e407cf3e965907cc134610b72e7a67972ba57f3bbe28178c84686f539')
+sha512sums_x86_64=('bf2945f3faed1ae54bc51407782e3288d7024808acb4e0be0a7b55e0b61b99f4a4b8be7a66d9d97584d5994f23a39f7a6df8079ec71f8ee1dfd2feec8b7dab3c')
+sha512sums_armv7h=('51cdcf09d04a8854eb6b9ee301a1e67d87d6e9b881c2f7672a7e7fe491beb63e8ac73b5736ebb81a457e8a5f9bc6c4a8f34711c53217df86037f5cb03b7f8058')
+# noextract=("heroku-v$pkgver-linux-x64.tar.xz" "heroku-v$pkgver-linux-arm.tar.xz")
+# noextract_armv7h=("heroku-v$pkgver-linux-x64.tar.xz" "heroku-v$pkgver-linux-arm.tar.xz")
options=('!strip')
+provides=('heroku' 'heroku-cli')
+
+prepare() {
+ # remove packaged node binary and fall back to whatever node is on the PATH
+ rm -f "$srcdir/heroku/bin/heroku"
+ rm -f "$srcdir/heroku/bin/heroku.cmd"
+ rm -f "$srcdir/heroku/bin/node"
+}
package() {
- npm install -g --user root --prefix "$pkgdir/usr" --cache "$srcdir/npm-cache" heroku-$pkgver.tgz
- mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
- ln -s "../../../lib/node_modules/heroku/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+ # https://cli-assets.heroku.com/linux-arm
+ # https://cli-assets.heroku.com/linux-x64
+
+ install -dm755 "$pkgdir/usr/lib/heroku"
+ install -dm755 "$pkgdir/usr/bin"
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+
+ herokulibdir="$pkgdir/usr/lib"
+ for foundherokudir in $(find "$srcdir/heroku" -mindepth 1 -type d) ; do
+ herokuinstalldir="${foundherokudir/$srcdir/$herokulibdir}"
+ install -dm755 "$herokuinstalldir"
+ done
- # npm makes some directories world writable
- find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+ for foundherokufile in $(find "$srcdir/heroku" -mindepth 1 -type f) ; do
+ herokuinstallperm=$(stat -c "%a" "$foundherokufile")
+ herokuinstallfile="${foundherokufile/$srcdir/$herokulibdir}"
+ install -Dm$herokuinstallperm "$foundherokufile" "$herokuinstallfile"
+ done
- # package files should always be owned by root:root
- chown -hR root:root "$pkgdir/usr"
+ ln -sf "../../../lib/heroku/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+ ln -sf "../../lib/heroku/bin/run" "$pkgdir/usr/bin/heroku"
}