summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmiel Wiedijk2018-07-26 11:53:16 +0200
committerEmiel Wiedijk2018-07-26 11:53:16 +0200
commit4511771d6f24133a11c6b795b340ab1775f5fcc5 (patch)
treecf169e6122adb246746b6f5a3384ba2556bb95a4
parent12ed2cf0ff1ba722d2aa3e5495fe9f990ecec47e (diff)
downloadaur-4511771d6f24133a11c6b795b340ab1775f5fcc5.tar.gz
Add options=(!strip)
The strip part took quite long compared to other packages on my system (3 minutes instead of max 10 seconds) and this package contains no binaries at all. Therefore, the build time is much shorter with !strip without big cost.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD1
2 files changed, 2 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22a415080560..a526c054887a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,7 @@ pkgbase = heroku-cli
conflicts = heroku-toolbelt
conflicts = ruby-heroku
noextract = heroku-7.7.6.tgz
+ options = !strip
source = https://registry.npmjs.org/heroku/-/heroku-7.7.6.tgz
md5sums = 9ced7cd527fc3dd1448a99a5026fff7f
diff --git a/PKGBUILD b/PKGBUILD
index 266672859234..c7d486a8aca3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,7 @@ optdepends=('git: Deploying to Heroku')
conflicts=('heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
source=("https://registry.npmjs.org/heroku/-/heroku-$pkgver.tgz")
noextract=("heroku-$pkgver.tgz")
+options=('!strip')
package() {
npm install -g --user root --prefix "$pkgdir/usr" heroku-$pkgver.tgz